Backlight support fails using Maverick 2.6.35-24

Reported by Drake Highfield on 2010-12-21
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Samsung Tools
Undecided
Unassigned

Bug Description

Backlight support fails (always at 100%) when booting Maverick with kernel version 2.6.35-24.
This affects at least: N150, N150+, N210, N220, NF310.

My configuration is: NF310, samsung-tools, samsung-backlight.
See also: http://www.voria.org/forum/viewtopic.php?f=3&t=625

(no logs available on my computer)

Solution: Adding
acpi_backlight=vendor
to the kernel's parameter list in your bootloader should do the trick.

See http://www.voria.org/forum/viewtopic.php?p=4399#p4399 (some technical detail) and http://www.voria.org/forum/viewtopic.php?p=4409#p4409 (step-by-step instructions).

Changed in samsung-tools:
status: New → Fix Committed
status: Fix Committed → New
nasraty-jebak (dusoft) wrote :

The instructions don't work for N150, tried multiple times. So please, reopen the bug.

Actually, it is still open. "Fix Commited" was set accidentally by me for a few minutes.

andrewlab (andrewlab) wrote :

I have N150-JA01RU. There was that bug, and after adding acpi_backlight=vendor, backlight support returned, but when netbook tried to lower lighting itself strange flickering effect revealed.

Disable "dim display when idle" in GNOME's power management (see http://www.voria.org/forum/viewtopic.php?p=4480#p4480).

Fortunato Ventre (voria) wrote :

This problem is not related to Samsung Tools, which has no part in hardware enablement.
Its work is to bind the already working FN keys (ie, enabled by udev at boot) to their specific functions they are intended to.
Also, Samsung Tools does not touch the backlight FN keys (Fn-Up, Fn-Down) in any way, since they usually work out of the box and no further actions are usually needed.

Instead, the backlight problem is likely to be caused by something new in the latest kernel 2.6.35-24, or by the 'samsung-backlight' kernel module, or by both. I'm sorry, I have no clues here. :(
My suggestion is to file a new bug against the linux kernel, and try to contact the developers of the 'samsung-backlight' module (project page: http://code.google.com/p/easy-slow-down-manager/).

In the meanwhile, I'm going to close this bug as invalid, since as I said the problem in not related to Samsung Tools.

Changed in samsung-tools:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers