Browsing samba shared printers show nothing

Bug #330883 reported by Patrice Vetsel on 2009-02-18
10
Affects Status Importance Assigned to Milestone
samba
Confirmed
Medium
samba (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: system-config-printer

I use a box to share printers on a windows network. It's a Trendnet TE100-P21
http://www.trendnet.com/products/proddetail.asp?prod=145_TE100-P21&cat=46

Using Jaunty and s-c-p 1.1.3+git20090217-0ubuntu1 I try to add network printers.

I use the Network Printer->Find Network Printer
add the IP (192.168.1.200)
click on "find"
-> but "No printer was found at that address."

I attach the screenshot of the trendnet configuration. You can see that there are multiple protocol enabled.

For informations printers attached to the Trendnet are :
Canon Pixma iX4000 (USB)
Epson EPL-5700 (//)

Patrice Vetsel (vetsel-patrice) wrote :
Patrice Vetsel (vetsel-patrice) wrote :

Last information :
Canon Pixma ix4000 is working great if I set it manually :
lpd://192.168.1.200/iX4000

using Canon iX5000 ppd (Gutenprint v5.2.3)

Patrice Vetsel (vetsel-patrice) wrote :

Here is what I get with windows xp browsing

summary: - Find Network Printer is not working
+ Browsing samba shared printers show nothing
Patrice Vetsel (vetsel-patrice) wrote :

Here is what I get with s-c-p samba browsing and output of debug :
using workgroup WORKGROUP 192.168.1.102
pysmb: got password callback
pysmb: got password callback
Closing connection (PPDs)
Releasing PPDs lock
parsed path: fname='smb://VETSEL/' server='VETSEL' share='' path='' options=''
SMBC_check_options(): server='VETSEL' share='' path='' options=''
pysmb: got password callback
pysmb: got password callback
parsed path: fname='smb://PS-70F869/' server='PS-70F869' share='' path='' options=''
SMBC_check_options(): server='PS-70F869' share='' path='' options=''
pysmb: got password callback
pysmb: got password callback
Canceled subscription 3
<monitor.Monitor instance at 0x1b429e0> exited
kagou@kagou-laptop:~$

Patrice Vetsel (vetsel-patrice) wrote :

In final and for information using nautilus samba browsing show nothing too but I don't know if it's a gnome bug, if gnome browsing should show printers, and if it's the same bug as in s-c-p

Patrice Vetsel (vetsel-patrice) wrote :

Is I add manually ps-70f869/ix4000 the test report that printer is accessible, so I add the printer, reporting YES to print the test page.

But nothing is print and I have a message in s-c-p :
"Unable to connect to CIFS host, will retry in 60 seconds..."

Patrice Vetsel (vetsel-patrice) wrote :

If I add manually the IP (but this IP can change).

lpd://192.168.1.100/ix4000 -> works ok !
smb://192.168.1.100/ix4000 -> don't works

Tim Waugh (twaugh) wrote :

What does 'smbclient -L Ps-70f869' say?

Patrice Vetsel (vetsel-patrice) wrote :

kagou@kagou-laptop:~$ smbclient -L Ps-70f869
Enter kagou's password:

 Sharename Type Comment
 --------- ---- -------

 Server Comment
 --------- -------

 Workgroup Master
 --------- -------
kagou@kagou-laptop:~$

Now output if you directly use Samba without any frontend (system-config-printer, CUPS, Nautilus, ...) -> Samba bug. Moving ...

affects: system-config-printer (Ubuntu) → samba (Ubuntu)
Changed in samba:
status: Unknown → Confirmed

As requested upstream here is the log.
launch of wireshark
capture
launch : smbclien -L PS-70F869
end capture
save as (no change to type : tcpdump/...libpcap)

For informations : samba is installed ! (not by default)
If I remove samba I have this :
smbclient -L PS-70F869
Connection to PS-70F869 failed (Error NT_STATUS_BAD_NETWORK-NAME)

Here is wireshark log from windows xp

Confirmed under final Ubuntu 9.04

Chuck Short (zulcss) wrote :

The fix seems to be in the works upstream. We will have to do an SRU when its fixed.

Regards
chuck

Changed in samba (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed

It's fixed now.

Changed in samba (Ubuntu):
status: Confirmed → Fix Released
Changed in samba:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.