Port Salience to GTK+3.6

Bug #1086671 reported by Christopher Kyle Horton on 2012-12-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Salience
Critical
Unassigned

Bug Description

Salience needs to be compatible with GTK+3.6 for compatibility with Ubuntu 12.10/13.04 and anything based off of those. This is a main project goal for the 2.0 release.

Related branches

kroq-gar78 (kroq-gar78) wrote :

Bumping the priority down because some initial fixes are present. Feel free to bump it back up if you feel it necessary.

Changed in salience:
importance: Critical → High

Bumping back up because we must have this done for 2.0, regardless of whatever fixes we already have. This bug is top-priority for the next release.

Changed in salience:
importance: High → Critical
kroq-gar78 (kroq-gar78) wrote :

Meant to say this earlier, but it seems like your branch has messed up a few minor things in Precise. I'll be looking into it.

kroq-gar78 (kroq-gar78) wrote :

For all who are interested, it seems like we'll have to change the focus of lp:salience to GTK 3.6+. Recent changes which were supposed to fix GTK 3.6 problems are breaking things on GTK 3.4. Thus, the decision has been made to use lp:salience/1.x as the branch for GTK+ releases of 3.4 and below.

Currently, I am in the process of merging all of the non-"harmful" commits from lp:salience (basically, everything until the most recent few) into lp:salience/1.x, and this branch will be the focus of all 3.4-related actions.

kroq-gar78 (kroq-gar78) wrote :

Having upgraded to 13.04 and used Salience 2.0, I can pretty safely say that this needs some major work. Luckily, I'll have a decent amount of free time to do that, and I'll also look into doing a switch of the parent theme (e.g. to Dorian).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers