sale_dropshipping: no dropshipping (by default) if stock available

Bug #1287779 reported by Alexandre Fayolle - camptocamp on 2014-03-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Sales - Workflow and Organization
Undecided
Unassigned

Bug Description

Case at hand: I have a product in MTO + buy + supplier does drop shipping.

If the virtual stock available is <=0 a SO for this product will be configured in drop shipping for the SO line.

OTOH, if there is some virtual stock, then the SO line will use the normal sale flow, regardless of the procurement method of the SO line. I think that the fact that the line type is make_to_order should prevent having a "normal" flow in this case, and that the check described above should only be performed for lines with type make_to_stock (in which case we want the order point to be substituted with a drop shipping).

Related branches

Revision history for this message
Nicolas Bessi - Camptocamp (nbessi-c2c-deactivatedaccount) wrote :

Hello,

Well practically it can be logic to use your stock first. But in other case you want to always use drop shipping as your supplier can have better condition when delivering product. IMHO this parameter should be at supplier info level, because you may want to have a given behavior by supplier. The problem is that the drop shipping check box does not offer enough flexibility.

I think one solution is to change the boolean fields on supplier info to a selection field with (standard, force drop shipping, drop shipping when no stock) and adapt code consequently.

Regards

Nicolas

Revision history for this message
Joël Grand-Guillaume @ camptocamp (jgrandguillaume-c2c) wrote :

Hi,

I also think that there is no "real" rules here and it probably depend a lot from the context of the company. The most important is not to break the backward compatibility here. We use it and override this module for 2 of our major customer so please be careful.

If the decision is to improve it, may be a second module should be made to prevent regression.

Regards,

Joël

Changed in sale-wkfl:
status: New → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers