Crash with vte-0.54

Bug #1790317 reported by Egmont Koblinger on 2018-09-01
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Sakura
High
Unassigned
sakura (Ubuntu)
Undecided
Unassigned

Bug Description

VTE changed certain things internally, and in turn Sakura crashes whenever its originally created tab is closed.

We think this is a bug in Sakura rather than VTE.

Please see https://gitlab.gnome.org/GNOME/vte/issues/32 for details.

(vte-0.54.0 will be released in about 2-3 days, until then you can see the crash with 0.53.92 or git master.)

Related branches

David Gómez (dabisu) wrote :

Thanks for the report, Egmont. I’ll look it into it ASAP (unfortunately that means two weeks :-/)

Egmont Koblinger (egmont-gmail) wrote :

Here's a draft patch. Needs thorough testing, and checking with older VTEs (maybe ifdefs or so).

The problem is a circular dependency, manually destroying (or removing from the hierarchy) the widget now emits child-exited, and on child-exited sakura removes it from the tree. This loop is broken by explicitly uninstalling the child-exited handler when Sakura initiates the removal of the widget.

tags: added: cosmic

The attachment "draft fix" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Jeremy Bicha (jbicha) wrote :

Egmont, thanks for testing sakura. Could you please forward this patch to Debian since sakura is maintained there? Debian has vte 0.54.0.

Jeremy Bicha (jbicha) wrote :

When you do have patches for Ubuntu, please subscribe ~ubuntu-sponsors so that the bug will automatically be added to http://reqorts.qa.ubuntu.com/reports/sponsoring/

David Gómez (dabisu) wrote :

Sorry for the delay. I've applied the patch to the main branch. Tests with vte 0.52 doesn't show any problems.

David Gómez (dabisu) on 2018-09-27
Changed in sakura:
importance: Undecided → High
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sakura (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

This bug was fixed in the package sakura - 3.6.0-3

---------------
sakura (3.6.0-3) unstable; urgency=medium

  * Refresh patches
  * Add patch to fix building with libvte 0.54 (Closes: #909744)

 -- Andreas Rönnquist <email address hidden> Thu, 27 Sep 2018 19:40:14 +0200

sakura (3.6.0-2) unstable; urgency=medium

  * Build-dep on libpcre2-dev (Closes: #906984)
  * Remove a newline at end of d/changelog

 -- Andreas Rönnquist <email address hidden> Wed, 22 Aug 2018 22:20:27 +0200

Changed in sakura (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.