Sahara exceptions use "components" even for single component

Bug #1312908 reported by Andrew Lazarev on 2014-04-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Sahara
Low
Talusani Mani Shanker

Bug Description

Observed: "Hadoop cluster should contain 1 oozie components."
Should be: "Hadoop cluster should contain 1 oozie component(s)."

Sergey Lukjanov (slukjanov) wrote :

"component(s)" is enough.

Changed in sahara:
milestone: none → juno-1
assignee: nobody → Andrew Lazarev (alazarev)
importance: Undecided → Critical
importance: Critical → Low
status: New → Triaged
description: updated
Changed in sahara:
assignee: Andrew Lazarev (alazarev) → nobody
milestone: juno-1 → none
tags: added: low-hanging-fruit
Changed in sahara:
assignee: nobody → Talusani Mani Shanker (shanker-mani0)
assignee: Talusani Mani Shanker (shanker-mani0) → nobody

I would like to work on this bug. Could anyone help me how to reproduce this bug and give me some pointers on how to fix this bug.

Changed in sahara:
assignee: nobody → Talusani Mani Shanker (shanker-mani0)
Sergey Lukjanov (slukjanov) wrote :

here are the all occurrences of this text - https://github.com/openstack/sahara/search?q=%22Hadoop+cluster+should+contain%22&ref=cmdform

so, you should "components." with "component(s)."

Changed in sahara:
milestone: none → juno-1
Changed in sahara:
status: Triaged → In Progress

Reviewed: https://review.openstack.org/91403
Committed: https://git.openstack.org/cgit/openstack/sahara/commit/?id=2736e2dabf7d6ffb2f201d64007db9dfca27ac86
Submitter: Jenkins
Branch: master

commit 2736e2dabf7d6ffb2f201d64007db9dfca27ac86
Author: Manishanker Talusani <email address hidden>
Date: Wed Apr 30 21:30:48 2014 +0530

    Replaced the word components with component(s)

    Current wording in exception messages of sahara
    is misleading

    Even when there is a single component, exceptions.py
    and test_job_executor.py use the word "components"
    instead of "component".

    Observed exception message was "Hadoop cluster
    should contain 1 oozie components.".
    Instead, the exception message should be
    "Hadoop cluster should contain 1 oozie component(s)."
    to avoid confusion.

    To avoid this confusion, the word "components" has
    been replaced with the word "component(s)"

    Closes-Bug : #1312908
    Change-Id: I6f385a52669bc05fb0bf28cacaf88688576c10c5

Changed in sahara:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2014-06-11
Changed in sahara:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-10-16
Changed in sahara:
milestone: juno-1 → 2014.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers