installer final step includes itself on homepage after redirect

Bug #746527 reported by Darlene McCullough
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Sahana Agasti
Status tracked in Mayon
Mayon
Confirmed
High
Unassigned

Bug Description

After the installer step 5, when the database builds, the user should be taken to a summary page and asked to click 'Finish' where they are re-directed to log in with the super admin credentials and create user accounts. Currently step 6 (the summary) creates an odd Frankenstein-page with the unauthenticated Home (see screenshot).

The workflow should be:
* Installer step 5
* Installer step 6
* User clicks 'Finish'
* Directed to "Home" page to log in with Super Admin credentials

Revision history for this message
Darlene McCullough (darlene-mccullough) wrote :
Usman A (usmonster)
summary: - installer step six errors
+ installer final step includes itself on homepage after redirect
Revision history for this message
Dhanushka Perera (dhanushka-ousl) wrote :

also the login seemed broken. It allows me to enter any kind of usr/pwd combination and I don't see any validations taken place.I have configured config.yml entering my super user uname and pwd as instructed in the interface, but when I try to login it says :

Not Found

The requested URL /sahana-agasti/web/login was not found on this server.

Revision history for this message
Usman A (usmonster) wrote :

Dhanushka: this seems like a separate issue not directly related to this bug; it looks like Apache's document root for Agasti might be set up one level too far. Can you review the INSTALL file, under Apache (steps 2 & 3) and verify your configuration? If you still think there is an issue after this, then please email the mailing list (<email address hidden>) for more troubleshooting, or file a separate new bug here.

Please also continue to comment here on anything more directly related to the original bug. Thanks!

Revision history for this message
Bernard Hoffman (bernardhoffman) wrote :

I have the same issue. Followed all the installation instructions and can't find a "login" file anywhere in the sahana-agasti folder and it doesn't seem to be produced by any script. So what gives... how can I login?

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments