Alfanous wouldn't load

Bug #783631 reported by Abdelmonam Kouka on 2011-05-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Alfanous - Quranic Search engine
Fix Released
High
Assem Chelli (عاصم شلي)
Sabily
Critical
أحمد المحمودي (Ahmed El-Mahmoudy)

Bug Description

Assalamo alaykom,

Alfanous was working fine, but after upgrading to natty it stop working! I try to install alfanousDesktop-linux-0.4r20.deb and I get a problem in install so I go to the last stable version: alfanousDesktop-linux-0.4r13.deb and this time it install..but the problem of load persist!
I run /usr/lib/alfanousDesktop/__init__.py and nothing happen,

so I run /usr/lib/alfanousDesktop/main.py and I got:
/usr/lib/alfanousDesktop/main.py: line 12: syntax error: unexpected end of file

so I run /usr/lib/alfanousDesktop/mainform.py and I got these errors:
kouka@kouka-laptop:~$ /usr/lib/alfanousDesktop/mainform.py
/usr/lib/alfanousDesktop/mainform.py: line 2: $'\r': command not found
/usr/lib/alfanousDesktop/mainform.py: line 9: $'\r': command not found
from: can't read /var/mail/PyQt4
/usr/lib/alfanousDesktop/mainform.py: line 11: $'\r': command not found
/usr/lib/alfanousDesktop/mainform.py: line 12: syntax error near unexpected token `('
'usr/lib/alfanousDesktop/mainform.py: line 12: `class Ui_MainWindow(object):

Changed in sabily:
importance: Undecided → Critical
assignee: nobody → Assem Chelli (عاصم شلي) (assem-ch)

Salam,

is this bug still open?

Changed in alfanous:
importance: Undecided → High

I did not make any change so I have the same config and the same pb!

After upgrading to 11.10 and re-installing Alfanous, I get this error when launching it:
kouka@kouka-desktop:~/Desktop$ python /usr/lib/alfanousDesktop
Searching for whoosh.egg
Reading http://pypi.python.org/simple/whoosh.egg/
Couldn't find index page for 'whoosh.egg' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading http://pypi.python.org/simple/
No local packages or download links found for whoosh.egg
error: Could not find suitable distribution for Requirement.parse('whoosh.egg')
Searching for alfanous.egg
Reading http://pypi.python.org/simple/alfanous.egg/
Couldn't find index page for 'alfanous.egg' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading http://pypi.python.org/simple/
No local packages or download links found for alfanous.egg
error: Could not find suitable distribution for Requirement.parse('alfanous.egg')
whoosh API is installed ...restart your program
python: can't open file '__main__.py': [Errno 2] No such file or directory
kouka@kouka-desktop:~/Desktop$

Changed in sabily:
status: New → Confirmed
Changed in alfanous:
status: New → Confirmed
Changed in alfanous:
assignee: nobody → Assem Chelli (عاصم شلي) (assem-ch)

Salam,

it needs to be re-packaged in a clean way , I haven't experience to handle
this but I think Ahmed almahmoody is already working on a new package.

2011/11/21 Abdelmonam Kouka <email address hidden>

> After upgrading to 11.10 and re-installing Alfanous, I get this error when
> launching it:
> kouka@kouka-desktop:~/Desktop$ python /usr/lib/alfanousDesktop
> Searching for whoosh.egg
> Reading http://pypi.python.org/simple/whoosh.egg/
> Couldn't find index page for 'whoosh.egg' (maybe misspelled?)
> Scanning index of all packages (this may take a while)
> Reading http://pypi.python.org/simple/
> No local packages or download links found for whoosh.egg
> error: Could not find suitable distribution for
> Requirement.parse('whoosh.egg')
> Searching for alfanous.egg
> Reading http://pypi.python.org/simple/alfanous.egg/
> Couldn't find index page for 'alfanous.egg' (maybe misspelled?)
> Scanning index of all packages (this may take a while)
> Reading http://pypi.python.org/simple/
> No local packages or download links found for alfanous.egg
> error: Could not find suitable distribution for
> Requirement.parse('alfanous.egg')
> whoosh API is installed ...restart your program
> python: can't open file '__main__.py': [Errno 2] No such file or directory
> kouka@kouka-desktop:~/Desktop$
>
> ** Changed in: sabily
> Status: New => Confirmed
>
> ** Changed in: alfanous
> Status: New => Confirmed
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/783631
>
> Title:
> Alfanous wouldn't load
>
> Status in Alfanous - Advanced Quranic Search Engine:
> Confirmed
> Status in Sabily:
> Confirmed
>
> Bug description:
> Assalamo alaykom,
>
> Alfanous was working fine, but after upgrading to natty it stop working!
> I try to install alfanousDesktop-linux-0.4r20.deb and I get a problem in
> install so I go to the last stable version:
> alfanousDesktop-linux-0.4r13.deb and this time it install..but the problem
> of load persist!
> I run /usr/lib/alfanousDesktop/__init__.py and nothing happen,
>
> so I run /usr/lib/alfanousDesktop/main.py and I got:
> /usr/lib/alfanousDesktop/main.py: line 12: syntax error: unexpected end
> of file
>
> so I run /usr/lib/alfanousDesktop/mainform.py and I got these errors:
> kouka@kouka-laptop:~$ /usr/lib/alfanousDesktop/mainform.py
> /usr/lib/alfanousDesktop/mainform.py: line 2: $'\r': command not found
> /usr/lib/alfanousDesktop/mainform.py: line 9: $'\r': command not found
> from: can't read /var/mail/PyQt4
> /usr/lib/alfanousDesktop/mainform.py: line 11: $'\r': command not found
> /usr/lib/alfanousDesktop/mainform.py: line 12: syntax error near
> unexpected token `('
> 'usr/lib/alfanousDesktop/mainform.py: line 12: `class
> Ui_MainWindow(object):
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/alfanous/+bug/783631/+subscriptions
>

OK, qo I will re-assign it to brother Ahmed.

Changed in sabily:
assignee: Assem Chelli (عاصم شلي) (assem-ch) → أحمد المحمودي (Ahmed El-Mahmoudy) (aelmahmoudy)
Changed in alfanous:
status: Confirmed → Fix Committed
Changed in sabily:
status: Confirmed → Fix Committed
Changed in alfanous:
status: Fix Committed → Fix Released
Changed in sabily:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers