Uninstalling Ryzom still leaves Ryzom data

Bug #997514 reported by Vadim Peretokin on 2012-05-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ryzom
Confirmed
Low
Cédric OCHS

Bug Description

I uninstalled Ryzom in order to make space - however there was till 6GB of game data left in ~/.ryzom.

This is a bug in the Ryzom packaging.

Reported upstream at http://dev.ryzom.com/issues/1483 .

---
WORKAROUND:

After uninstalling Ryzom, open a terminal and type the following to remove the local data files and free up the space:

  $ rm -r ~/.ryzom/
---

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: software-center 5.2.1
ProcVersionSignature: Ubuntu 3.2.0-24.38-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Thu May 10 18:14:49 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_AU:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: Upgraded to precise on 2012-04-26 (13 days ago)

Vadim Peretokin (vperetokin) wrote :
kroq-gar78 (kroq-gar78) wrote :

This should really be affecting the package 'ryzom', but Launchpad won't let me do that, saying that it's not yet published.

Gary Lasker (gary-lasker) wrote :

I'm in the process of verifying this. It takes quite a while to start Ryzom first time after you install it, 'cuz it downloads all the data files! Anyway, I see it all going into ~/.ryzom, as reported by Vadim. Once I've verified this is not cleared on an install, I'll finish triaging this bug.

Thanks!

Changed in software-center (Ubuntu):
status: New → Incomplete
Gary Lasker (gary-lasker) wrote :

Indeed, I can confirm that the massive local data set remains after uninstall. For now (I'm sure you know), a workaround is to open a terminal and type:

  $ rm -r ~/.ryzom/

  I will file a bug upstream for the Ryzom project.

Changed in software-center (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Low
status: Confirmed → Invalid
Gary Lasker (gary-lasker) wrote :

Set to invalid for the software-center package as this bug is in the packaging for Ryzom itself.

description: updated
Gary Lasker (gary-lasker) wrote :

I filed a report with the upstream Ryzom devs here:

  http://dev.ryzom.com/issues/1483

description: updated
Cédric OCHS (kervala) wrote :

Hi !

I'm the maintainer of Ryzom package.

Thanks for reporting that, but that was intended !

Before downloading data in ~/.ryzom, we were putting them in /usr/share/games/ryzom and it was worst ! Because even if we were able to remove them while uninstalling the package, a lot of people have a limited space in their / partition and 6 GB is too much.

Dowloading into ~/.ryzom was a suggestion by Canonical employees themselves.

Now imagine we delete ~/.ryzom after package uninstall, all personal infos are deleted too (interface saves, landmarks, screenshots, chat logs, etc...). If we try to delete only ~./ryzom/data (the 6 GB data), how the uninstaller will know where are located these data because each user can have a copy ? What if a user uninstalled it to reinstall it later ? He'll have to redownload all 6 GB.

All applications put their data in ~ and some of them are using more disk space as other, do you know any application who delete files in ~ while being uninstalled ?

When launching Baobab, the user will notice there is a folder taking more than 6 GB and will be able to remove it manually if that's his choice. Instead of forcing something (Apple or Microsoft policies), I prefer to let the choice.

Eventually, perhaps I could add a dialog message at the end of patching process that if he want to free 6 GB, the user have to manually delete the ~/.ryzom/data directory.

Gary Lasker (gary-lasker) wrote :

Hi Cédric! Thank you very much for your detailed explanation! It's very helpful to know all of the background behind this. Indeed, the only reason it's an issue is the sheer size of the data files that remain behind after an uninstall.

I agree that you wouldn't want to remove all of the user's preferences, etc., so that they don't lose this information for when they want to reinstall and take up where they left off. :) However, the vast bulk of the data files must be static, correct? I would think maybe they could be stored in a different place and removed on an uninstall to free that space. Of course, it's true that you would then have to redownload that giant file at first startup again.

This is a tradeoff best left to you and your team to decide. I just wanted you to know that we've had this report.

I very much appreciate your thoughtful reply and your help!!

Best regards,
Gary

Vadim Peretokin (vperetokin) wrote :

I'd like to think that I as a user, removed Ryzom for the very reason of
saving space because I wasn't interested in the game anymore. If I have to
redownload the game again because I removed it (and it is very hard to do
it by accident, so that can be ruled out), then it was a decision I made...

Cédric OCHS (kervala) wrote :

Hi there !

I'm sorry I didn't get noticed for your responses (I just subscribed this report today), but I plan to fix it for next patch. I'll use debconfig to ask user if he want to keep downloaded data. If no, the script will delete all ~/.ryzom/data from all users.

Thanks !

Cédric

affects: software-center (Ubuntu) → ryzom
Changed in ryzom:
assignee: nobody → Cédric OCHS (kervala)
status: Invalid → Confirmed
Cédric OCHS (kervala) wrote :

Hi,

The last version of the Ryzom package takes into account the "purge" command and delete downloaded data.

The problem is Ubuntu Software Center doesn't have any button to "purge" data... So the only way, for the moment, is to use Synaptic, aptitude, apt-get, etc...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers