guile2 support

Bug #782750 reported by oget on 2011-05-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rumor
Undecided
Unassigned

Bug Description

Hi, Fedora is updating guile to 2.0.1, and rumor needs to be updated, as the gh methods in guile are now deprecated. I made this patch for guile2 compatibility and did some minimal testing. Note that the patch is one-way, it is _not_ backwards compatible with earlier versions of guile.

Please check the patch. I used the following documentation as reference for transition:
https://www.endsoftwarepatents.org/software/guile/docs/docs-1.8/guile-ref/Transitioning-away-from-GH.html

Thanks.

oget (oget-fedora) wrote :
Václav Šmilauer (eudoxos) wrote :

Hi, I am seeing this bug with 6-year delay, sorry for that. I will apply the patch soon. Thanks for reporting! Vaclav

Václav Šmilauer (eudoxos) wrote :

Applied in the repo. Thank you!

Changed in rumor:
status: New → Fix Committed
oget (oget-fedora) wrote :

Thanks! Better late than never :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers