Rubber — a wrapper for LaTeX and friends

does not interpret directives if comment character is preceded by spaces

Reported by Dan Drake on 2008-02-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Rubber
Medium
Paul Kishimoto
rubber (Debian)
Fix Released
Unknown
rubber (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: rubber

Rubber does not interpret directives if the comment character is preceded by spaces: it will read

% rubber: read /path/foo

but not

  % rubber: read /path/foo

The attached patch fixes the problem. It has Rubber look for a regexp instead of "%" at the beginning of the line.

I am using 1.1-2.1ubuntu1 on gutsy.

Dan Drake (ddrake) wrote :
Daniel Holbach (dholbach) wrote :

To get your fix included in Ubuntu, it would help if you tried transforming it into a debdiff (http://wiki.ubuntu.com/PackagingGuide/Recipes/Debdiff) and submit it for review (http://wiki.ubuntu.com/SponsorshipProcess). If you prefer somebody else to do that, that's fine - please just indicate if you're available to do that.

Dan Drake (ddrake) wrote :

I will try to get a debdiff prepared. Thanks for the URLs.

Dan Drake (ddrake) wrote :

I created a debdiff according to the instructions you gave. I hope I did it properly. It's a very minor change and I hope it can be introduced into the next version of the package.

Dan Drake (ddrake) wrote :

Is anything going to be done about this bug? It's been nearly a month since I uploaded my debdiff and the package has not been updated and there are no comments here saying that the debdiff is incorrect or that the bug isn't actually a bug, etc.

Dan Drake (ddrake) wrote :

To repeat myself: is anything going to be done about this bug?

I went to the trouble of reporting the bug and making patches in the first place because a lot of the hype surrounding Ubuntu is about its community, and I thought a simple bug report, accompanied by a patch, would (at the very least) not be ignored by the package maintainer.

At this point -- five months after the initial report -- I can't help but wonder if Ubuntu is more cathedral than bazaar. Am I expected to show up to church on Sunday and listen -- install the releases every April and October -- or can I spread out a blanket at the market and hawk my patches and bug reports, and feel like my contributions are welcome?

Paul Kishimoto (khaeru) wrote :

Dan, have you tried contacting Emmanuel Beffara, developer of rubber? The project home page is at http://www.pps.jussieu.fr/~beffara/soft/rubber/

Upstream communication in Ubuntu is a lot more fluid with larger projects like GNOME than it is with small ones like rubber. This seems sensible to me. I'm not a dev or a MOTU, but it's apparent that package maintainers can't start updating stale source packages, unless they are of high importance to many users. That amounts to assuming maintenance responsibility not just for the packaging (as in https://launchpad.net/ubuntu/intrepid/+source/rubber/1.1-2.2, this August) but for the source itself, and is probably pretty burdensome. I love rubber, but I don't think it fits that high-profile category.

Let's try and get Mr. Beffara to push out another release, so the maintainers can simply refresh the source with the same packaging.

Daniel T Chen (crimsun) wrote :

Sorry about the latency (resource issue). I'll take a look.

Changed in rubber:
assignee: nobody → crimsun
importance: Undecided → Low
status: New → Triaged
Paul Kishimoto (khaeru) on 2009-11-23
Changed in rubber:
assignee: nobody → Paul Kishimoto (khaeru)
importance: Undecided → Medium
milestone: none → 1.2
status: New → Fix Committed
Alex Valavanis (valavanisalex) wrote :

Hi Dan,

I have created a new debdiff simply to update the version numbers. I'll also subscribe the appropriate sponsors to this report, so that your changes can be uploaded.

Changed in rubber (Debian):
status: Unknown → New
Changed in rubber (Ubuntu):
assignee: Daniel T Chen (crimsun) → nobody
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rubber - 1.1-2.2ubuntu2

---------------
rubber (1.1-2.2ubuntu2) maverick; urgency=low

  * src/rules/latex/__init__.py:
    - Use regexp to look for directives, so that comment mark needn't be at
        beginning of line (LP: #195258). Patch by Dan Drake
 -- Alexander Valavanis <email address hidden> Mon, 08 Mar 2010 08:51:02 +0000

Changed in rubber (Ubuntu):
status: Fix Committed → Fix Released
Changed in rubber (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.