Updating rsyslog hangs, waiting for rsyslogd process to die

Bug #1187654 reported by Michael Mess
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Rsyslog
New
Undecided
Unassigned
rsyslog (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Updater hangs while updating rsyslog, waiting for the rsyslogd process to die.

Workaround:

 * Login as root and kill the process named 'rsyslogd -c5'

Then the update continues.

Tags: precise
Revision history for this message
Michael Mess (michael-michaelmess) wrote :
Changed in pulseaudio (Ubuntu):
status: New → Invalid
affects: pulseaudio (Ubuntu) → rsyslog (Ubuntu)
Changed in rsyslog (Ubuntu):
status: Invalid → New
Revision history for this message
Anders Kaseorg (andersk) wrote :

Is this bug 1187808?

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rsyslog (Ubuntu):
status: New → Confirmed
Revision history for this message
Michael Mess (michael-michaelmess) wrote :

This is not bug 1187808, because there rsyslog didn`t start.

Here it was running and didn't stop before updating and had to de killed by hand.

Revision history for this message
Peter Tripp (notpeter) wrote :

Still broken. I've ran into this mid dist-upgrade on an Ubuntu 14.04.1 LTS (Trusty) system.

Revision history for this message
Adgenodux (tempo-data) wrote :

have same problem after upgrade of the server version from 15.04 to 15.10

as the rsyslog-postinst still remain into the global upgrade process, you always need to kill his memory process to complete the system upgrade...

however, rsyslog looks working correctly...

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers