RockWork stopped recognising my Pebble

Bug #1598958 reported by Daniel Ekelund on 2016-07-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
RockWork
Undecided
Unassigned

Bug Description

Earlier today my Ubuntu Phone reached 100% disk usage, this is probably related to BUG #1539864.
I removed a log-file of 15 GB, and was able to start using my phone again, except for RockWork.

Now it's showing the "startup-animation" for approximately five minutes. Then suddenly it complains: "Your Pebble smartwatch is disconnected". I have tried to remove and readd the device via Ubuntus system settings, and the same thing via Pebbles system settings. But this is without luck.

Note: I have also used my Pebble together with my iPhone (RunKeeper) during the day, and both devices (Ubuntu and iPhone) was connected to the device at the same time without any problems. I don't think this is related to the issue(?).

I'm looking for a workaround to get it up and running again, is it possible to remove configuration files to "reset" the RockWork setup? And if so, where do I find the configuration?

(I have tried to rename ~/.config/Unknown\ Organization/rockworkd.conf to rockworkd.conf.old, and restarted the system, but without any luck)

Michael Zanetti (mzanetti) wrote :

you can try to delete:

~/.local/share/rockworkd/
~/.config/rockwork/

(the ~/.config/Unknown Organization/rockworkd.conf seems a bug... will look into that)

Daniel Ekelund (daniel.ekelund) wrote :

~/.config/rockwork didn't exist, but I moved ~/.local/share/rockworkd to /tmp and that resolved my problem.

Thanks for the rapid support

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers