Unspecified is not a tag but a clue to specify a reason for moderation

Bug #733366 reported by Dave Morley on 2011-03-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ratings and Reviews server
Undecided
Unassigned
software-center (Ubuntu)
Undecided
Aaron Peachey

Bug Description

Bug Description:
Under moderations there is a tag called Unspecified currently. After talking to mpt it turns out that this is not meant to be a tag but a note to the user to specify a reason.
We need to make it so the user can't send info to moderations if the tag is set to Unspecified.

Version:
Django 1.1.1
Python 2.6.5 (r265:79063, Apr 16 2010, 14:15:55) [GCC 4.4.3]
preflight 0.1
rnr-server 11.01
openid 2.2.1
launchpadlib 1.6.0
piston 0.2.2
South 0.6

OS:
64bit Maverick

Browser:
FF 3.6.15

Problem URL:
n/a

Steps To Reproduce:
1. Open software-center
2. Select a package and write a review
3. Once the review shows up in SC mark it inappropriate
4. Note the Unspecified. Leave it on that and then make a note as to the issue.

Expected Result:
This was bought about as to why we had unspecified and other tags, at which point I was told unspecified is a clue to the user to specify a reason not a tag to submit on.

With that in mind the review should fail to send if Unspecified is selected. Maybe we could make the Unspecified a different colour to help identify this as not being a tag.

Matthew Paul Thomas (mpt) wrote :

There are two main purposes for the reason type selection. One is so that, if we ever start getting hundreds of flags, we can funnel them directly to the appropriate people (e.g. legal problems to a lawyer, offensive language problems to a moderator). The other is to discourage people from flagging a review just because they don't like it.

For both of those purposes, it helps if the default reason type is one that you can't submit. It's okay if you have to think a bit before submitting. Perhaps the default option should be labelled "Choose a reason" instead of "Unspecified".

Aaron Peachey (aaronp) on 2011-03-12
Changed in software-center (Ubuntu):
status: New → In Progress
assignee: nobody → Aaron Peachey (aaronp)
Aaron Peachey (aaronp) wrote :

Branch attached fixes the issue in software centre. Changes unspecified to now say 'Please make a selection...' but doesn't allow the submit button to become sensitive unless the user chooses a different option from the combobox.

Aaron Peachey (aaronp) on 2011-03-14
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.23.3

---------------
software-center (3.1.23.3) natty; urgency=low

  [ Aaron Peachey ]
  * utils/submit_review.py:
    - Remove 'unspecified' reason and disable submit button if
      no reason selected for report abuse (LP: #733366)
  * softwarecenter/db/reviews.py, view/appdetailsview_gtk.py,
    view/widgets/reviews.py:
    - refresh usefulness object with latest vote after successful
      usefulness submit, so review UI is updated correctly
      (LP: #736312)

  [ Michael Vogt ]
  * add SOFTWARE_CENTER_FORCE_NON_SSL environment to allow
    testing against a local django server
  * software-center:
    - fix spelling error in --help output, thanks to
      Robbie Williamson
  * softwarecenter/backend/zeitgeist_simple.py:
    - fix crash with the new zeitgeist version
 -- Michael Vogt <email address hidden> Thu, 17 Mar 2011 13:59:15 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Michael Nelson (michael.nelson) wrote :

I don't think this requires changes on the server does it? Marking invalid, but let me know if there are changes required.

Changed in rnr-server:
status: New → Invalid
no longer affects: software-center
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers