No music in 0.9.7

Reported by telverston on 2011-08-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Riven X
Fix Released
Critical
Jean-Francois Roy

Bug Description

All sound effects are working, but none of the ambient music is coming on. I have deleted the previous preferences files, and also I created a new game on 0.9.7

I am running on an iMac core 2 duo 3.06 with 4 gigs ram. I am using the digital output via fiber optic line.

I have been around in the environment to a few islands trying to trigger music. No avail.

I have not tried to reinstall the source files, but they seem to work fine.

Intro music does play. No ambient music plays in game however.

Not sure which version I loaded, I think it's the DVD 10 anniversary edition now. I used to play from the CD version.

Nothing really interesting in the logs, but here is an excerpt:

8/2/11 2:42:29 PM [0x0-0x20b20b].org.macstorm.rivenx[4357] 2011-08-02 14:42:29 -0400 [script] [AUDIO] <RXCardState: 0x896200>: failed to get audio decompressor for sound ID 1
8/2/11 3:16:23 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] Riven X debug shell v4.
8/2/11 3:16:35 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] dlopen(/Applications/Riven X.app/Contents/Frameworks/MHKKit.framework/Resources/libavcodec.dylib, 9): Library not loaded: @loader_path/libavcore.dylib
8/2/11 3:16:35 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] Referenced from: /Applications/Riven X.app/Contents/Frameworks/MHKKit.framework/Resources/libavcodec.dylib
8/2/11 3:16:35 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] Reason: image not found
8/2/11 3:16:35 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] 2011-08-02 15:16:35 -0400 [script] [AUDIO] <RXCardState: 0xa0a400>: failed to get audio decompressor for sound ID 1
8/2/11 3:16:48 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] 2011-08-02 15:16:48 -0400 [script] [AUDIO] <RXCardState: 0xa0a400>: failed to get audio decompressor for sound ID 1
8/2/11 3:16:48 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] 2011-08-02 15:16:48 -0400 [script] [AUDIO] <RXCardState: 0xa0a400>: failed to get audio decompressor for sound ID 1
8/2/11 3:17:00 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] 2011-08-02 15:17:00 -0400 [script] [AUDIO] <RXCardState: 0xa0a400>: failed to get audio decompressor for sound ID 1
8/2/11 3:17:02 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] 2011-08-02 15:17:02 -0400 [script] [AUDIO] <RXCardState: 0xa0a400>: failed to get audio decompressor for sound ID 1
8/2/11 3:17:04 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] 2011-08-02 15:17:04 -0400 [script] [AUDIO] <RXCardState: 0xa0a400>: failed to get audio decompressor for sound ID 1
8/2/11 3:17:10 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] 2011-08-02 15:17:10 -0400 [script] [AUDIO] <RXCardState: 0xa0a400>: failed to get audio decompressor for sound ID 1
8/2/11 3:17:11 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] 2011-08-02 15:17:11 -0400 [script] [AUDIO] <RXCardState: 0xa0a400>: failed to get audio decompressor for sound ID 1
8/2/11 3:17:11 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] 2011-08-02 15:17:11 -0400 [script] [AUDIO] <RXCardState: 0xa0a400>: failed to get audio decompressor for sound ID 3
8/2/11 3:17:19 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] 2011-08-02 15:17:19 -0400 [script] [AUDIO] <RXCardState: 0xa0a400>: failed to get audio decompressor for sound ID 1
8/2/11 3:17:20 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] 2011-08-02 15:17:20 -0400 [script] [AUDIO] <RXCardState: 0xa0a400>: failed to get audio decompressor for sound ID 1
8/2/11 3:17:21 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] 2011-08-02 15:17:21 -0400 [script] [AUDIO] <RXCardState: 0xa0a400>: failed to get audio decompressor for sound ID 1
8/2/11 3:20:45 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] 2011-08-02 15:20:45 -0400 [script] [AUDIO] <RXCardState: 0xa0a400>: failed to get audio decompressor for sound ID 6
8/2/11 3:20:47 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] 2011-08-02 15:20:47 -0400 [script] [AUDIO] <RXCardState: 0xa0a400>: failed to get audio decompressor for sound ID 6
8/2/11 3:20:48 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] 2011-08-02 15:20:48 -0400 [script] [AUDIO] <RXCardState: 0xa0a400>: failed to get audio decompressor for sound ID 6
8/2/11 3:20:50 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] 2011-08-02 15:20:50 -0400 [script] [AUDIO] <RXCardState: 0xa0a400>: failed to get audio decompressor for sound ID 6
8/2/11 3:20:57 PM [0x0-0x21f21f].org.macstorm.rivenx[4532] 2011-08-02 15:20:57 -0400 [script] [AUDIO] <RXCardState: 0xa0a400>: failed to get audio decompressor for sound ID 1
8/2/11 3:25:30 PM [0x0-0x221221].org.macstorm.rivenx[4591] Riven X debug shell v4.
8/2/11 3:25:31 PM [0x0-0x221221].org.macstorm.rivenx[4591] dlopen(/Applications/Riven X.app/Contents/Frameworks/MHKKit.framework/Resources/libavcodec.dylib, 9): Library not loaded: @loader_path/libavcore.dylib
8/2/11 3:25:31 PM [0x0-0x221221].org.macstorm.rivenx[4591] Referenced from: /Applications/Riven X.app/Contents/Frameworks/MHKKit.framework/Resources/libavcodec.dylib
8/2/11 3:25:31 PM [0x0-0x221221].org.macstorm.rivenx[4591] Reason: image not found
8/2/11 3:25:31 PM [0x0-0x221221].org.macstorm.rivenx[4591] 2011-08-02 15:25:31 -0400 [script] [AUDIO] <RXCardState: 0x9f9a00>: failed to get audio decompressor for sound ID 1
8/2/11 3:25:43 PM [0x0-0x221221].org.macstorm.rivenx[4591] 2011-08-02 15:25:43 -0400 [script] [AUDIO] <RXCardState: 0x9f9a00>: failed to get audio decompressor for sound ID 1
8/2/11 3:25:44 PM [0x0-0x221221].org.macstorm.rivenx[4591] 2011-08-02 15:25:44 -0400 [script] [AUDIO] <RXCardState: 0x9f9a00>: failed to get audio decompressor for sound ID 1
8/2/11 3:25:45 PM [0x0-0x221221].org.macstorm.rivenx[4591] 2011-08-02 15:25:45 -0400 [script] [AUDIO] <RXCardState: 0x9f9a00>: failed to get audio decompressor for sound ID 1
8/2/11 3:25:46 PM [0x0-0x221221].org.macstorm.rivenx[4591] 2011-08-02 15:25:46 -0400 [script] [AUDIO] <RXCardState: 0x9f9a00>: failed to get audio decompressor for sound ID 1
8/2/11 3:25:46 PM [0x0-0x221221].org.macstorm.rivenx[4591] 2011-08-02 15:25:46 -0400 [script] [AUDIO] <RXCardState: 0x9f9a00>: failed to get audio decompressor for sound ID 4
8/2/11 3:25:56 PM [0x0-0x221221].org.macstorm.rivenx[4591] 2011-08-02 15:25:56 -0400 [script] [AUDIO] <RXCardState: 0x9f9a00>: failed to get audio decompressor for sound ID 1
8/2/11 3:25:56 PM [0x0-0x221221].org.macstorm.rivenx[4591] 2011-08-02 15:25:56 -0400 [script] [AUDIO] <RXCardState: 0x9f9a00>: failed to get audio decompressor for sound ID 1
8/2/11 3:25:56 PM [0x0-0x221221].org.macstorm.rivenx[4591] 2011-08-02 15:25:56 -0400 [script] [AUDIO] <RXCardState: 0x9f9a00>: failed to get audio decompressor for sound ID 7
8/2/11 3:25:56 PM [0x0-0x221221].org.macstorm.rivenx[4591] 2011-08-02 15:25:56 -0400 [script] [AUDIO] <RXCardState: 0x9f9a00>: failed to get audio decompressor for sound ID 1

Changed in rivenx:
assignee: nobody → Jean-Francois Roy (jeanfrancois.roy)
milestone: none → 1.0

Fixed in Riven X 0.9.8.

Changed in rivenx:
status: New → Fix Released
importance: Undecided → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers