TouchPad buttons don't work on HP Mini 210 (1030NR)

Bug #516329 reported by Anmar Oueja on 2010-02-02
192
This bug affects 34 people
Affects Status Importance Assigned to Milestone
Ripspread
Medium
Chase Douglas
XOrg-Driver-Synaptics
Invalid
Undecided
Unassigned
xserver-xorg-input-synaptics (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:

1. Install Lucid Alpha2 CD
2. try the left button and right buttons and they don't work. What work is the click on the touchpad.

The touchpad is similar design to Apple's touchpad.

please note that if I disable "enable clicks with touchpad" none of the buttons work (left and right clicks)

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: anmar 1545 F.... pulseaudio
 /dev/snd/pcmC0D0p: anmar 1545 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x58200000 irq 16'
   Mixer name : 'IDT 92HD81B1X5'
   Components : 'HDA:111d7605,103c3660,00100402'
   Controls : 14
   Simple ctrls : 9
Date: Tue Feb 2 15:29:15 2010
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=91a461d2-ba2a-4d16-bc3c-590701bd82e1
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100113)
MachineType: Hewlett-Packard HP Mini 210-1000
Package: linux-image-2.6.32-12-generic 2.6.32-12.16
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-12-generic root=UUID=d4ff37b4-8a6d-4672-9eb5-d37c98d25824 ro quiet splash
ProcEnviron:
 LANG=en_CA.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.16-generic
Regression: No
RelatedPackageVersions: linux-firmware 1.28
Reproducible: Yes
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
TestedUpstream: No
Uname: Linux 2.6.32-12-generic i686
dmi.bios.date: 12/22/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.03
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3660
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 48.10
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.03:bd12/22/2009:svnHewlett-Packard:pnHPMini210-1000:pvr04A3100000202100000300000:rvnHewlett-Packard:rn3660:rvr48.10:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP Mini 210-1000
dmi.product.version: 04A3100000202100000300000
dmi.sys.vendor: Hewlett-Packard

Anmar Oueja (anmar) wrote :
Anmar Oueja (anmar) wrote :

I tried the latest kernel from the PPA (http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.33-rc6/) and had the same result.

I am very eager to resolve this because it is a big bug for all of the HP mini 210 netbooks and they are popular on the net and Amazon.

Andy Whitcroft (apw) on 2010-02-04
Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in linux (Ubuntu):
status: New → Triaged
Paul C. Bryan (pbryan) wrote :

There is a workaround (posted in German), which supports right-click, but at the expense of any Synaptics enhanced functionality such as scrolling by dragging on the right side of the trackpad:
http://greendevnet.blogspot.com/2009/10/ubuntu-910-karmic-koala-no-touchpad.html

Also, here's a discussion I found on the topic of this new trackpad by kernel developers:
http://thread.gmane.org/gmane.linux.kernel/926825

Anmar Oueja (anmar) wrote :

Hello Paul: Good feedback. Unfortunately, the fix is more of a regression than anything else. This is a synaptics toucpad so it shouldn't be too difficult to enable it. I am sure it is a kernel thing.

Gabriel Bauman (gabrielbauman) wrote :

The Synaptics touchpad in question is a new model, known as a "clickpad". It actually has a single physical button underneath the bottom edge of the touchpad, and the driver is supposed to determine whether the click is "left" or "right" by looking at finger position on the pad.

It's important to realize that the "workaround" that people are using basically makes the pad appear as a PS/2 mouse to the kernel. This means no edge or two-finger scrolling, and the touchpad will stay active when typing. Not optimal.

There are two patches in development. One is to the Synaptics X driver; the other is to the kernel. BOTH of the patches will be necessary to get the proper behaviour. Read the mailing list thread posted by Paul for details.

Both the Ubuntu X team and the Kernel team will need to collaborate on a fix. Getting late for Lucid now.

Alberto, can you please take a look and see if there is something we should be doing here?

Changed in xorg-driver-synaptics:
assignee: nobody → Alberto Milone (albertomilone)
Gabriel Bauman (gabrielbauman) wrote :

Some users are having success patching the kernel to add clickpad support. See the Ubuntu Forums thread here:

 o http://swiss.ubuntuforums.org/showthread.php?p=9037468

The patch they are using is based on work at:

 o http://patchwork.kernel.org/patch/67335/

Note that if you've used the psmouse workaround, you'll need to remove it before the patch will work.

Anmar Oueja (anmar) wrote :

I am not sure if this is possible since the kernel freeze but can we push this into Lucid's kernel? if not what is the alternative.

Changed in linux (Ubuntu):
assignee: nobody → Ubuntu Kernel Team (ubuntu-kernel-team)
Anmar Oueja (anmar) wrote :

Just so things are in perspective. This issue will fix the touch pad buttons for the 5th most popular laptop on Amazon (http://www.amazon.com/gp/bestsellers/pc/1232596011)

Ákos Maróy (akos-maroy) wrote :

same here, on an HP Envy 15

a kernel patch can be found here: http://www.spinics.net/lists/linux-input/msg06333.html

but its tedious to manually patch the kernel always

Changed in linux (Ubuntu):
status: Triaged → In Progress
assignee: Ubuntu Kernel Team (ubuntu-kernel-team) → Chase Douglas (chasedouglas)
Chase Douglas (chasedouglas) wrote :

I've created a test kernel with the patch Ákos Maróy posted. Please test it out and report back on how it works. We'll need to know very soon (within a day or two) for it to get into the 10.04 release image. Otherwise it will need to be deferred to a release update.

http://people.canonical.com/~cndougla/516329/linux-image-2.6.32-19-generic_2.6.32-19.29~lp516329_i386.deb

Thanks

Peter Magnusson (kmpm) wrote :

Tested and can only confirm that it works, I can click both buttons, scroll and use the "clickpad" as expected and nothing else breaks.
Good job.

I know it's asking for much but how about two finger scroll now :-)

Just to clarify (sorry if I am stating the obvious), there are two issues here.

1] The touchpad buttons do not work at all (focus of this bug)

I could fully resolve the issue by at least two ways.
- The patched kernel proposed in Comment #11
- The "clickpad.tar.gz" patch proposed in Comment #5, which does not require a kernel recompilation and works happily with 2.6.31-20-generic #58 on Karmic.

I am relieved to be able to click again on my Mini 210.

2] The Clickpad "extra functionalities" do not work

Again, Comment #5 is very insightful on this.

http://www.synaptics.com/solutions/products/clickpad
"ClickButtons deliver an advanced gesture experience. This zone less option enables the user to left- or right-click anywhere on the ClickPad. Pressing one finger down performs a left click. Pressing two fingers down performs a right click. The user doesn’t need to look away from the computer screen to find the ClickZone, or try to locate it by feel."

As far as I could test on my Mini 210 running Karmic, the updated kernel on Comment #11 does not provide the extra clickpad functionalities. Or did I miss something?

An easy way to test this for me was to click with two fingers outside of the 2 clicking areas: the pointer randomly moves, but no (right) click occurs.

Also if I click in the marked zones while another finger is somewhere else on the clickpad, the pointer may randomly moves but in any case no click occurs.

Basically, clicking outside of the clicking zones still does not work for me.

Again, I am running on Karmic, not on Lucid. I will test on Lucid asap.

Have others succeeded in getting the extra clickpad functionalities working on either Karmic or Lucid?

Chase Douglas (chasedouglas) wrote :

The kernel patch allows basic clicking functionality. For the true "clickpad" functionality you describe, the X synaptics driver needs to be involved according to the upstream linux-input mailing list.

My suggestion is that we invalidate the X synaptics bug here and that a new bug be opened against it alone. It's easiest for people to follow along if only one issue is tracked per bug.

Thanks

Alberto Milone (albertomilone) wrote :

Sorry for the late reply. Adding the following patch to the X driver should give you back middle click:
http://www.spinics.net/lists/linux-input/msg06327.html

I can make a package with this patch and put it in a PPA for testing. I'll let you know when it's ready.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Triaged
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → Medium
Changed in xorg-driver-synaptics:
assignee: Alberto Milone (albertomilone) → nobody
Peter Magnusson (kmpm) wrote :

As RomainWartel said in comment #13. The first kernel patch here (comment #11) only enables right click. Nothing else. Other stuff as two finger scroll, pinch to zoom etc that works in Windows doesn't. Not on my Mini 210 and probably not on anything else either because of what the patch actually does.

But hey.... Now I can actually use Ubuntu on my computer without being forced to have an external mouse. Just make sure that fix gets in or I'll have to wait another 6 months before booting in Ubuntu again.

Alberto Milone (albertomilone) wrote :

@Peter
The kernel patch will give you right click while the x patch will give you middle click. This is what I consider bugs which, in my opinion, is something that we can still fix in Lucid (as we're in feature freeze).

Anything else (mainly gestures) is a feature and should be implemented upstream (unfortunately I lack the hardware to do so) and of course won't make it into this Ubuntu release cycle.

Anmar Oueja (anmar) wrote :

Hello Alberto:

does that mean if you had the hardware, you can make the gestures work?

Alberto Milone (albertomilone) wrote :

@Anmar
I can make sure that features such as ClickButtons and ClickZones work well in the X driver (this might be a matter of adding an Xinput property or two, I guess).

Gestures, however, require a multitouch driver. This is a non trivial task but I *think* upstream is working on it already.

I agree with Chase in Comment #14, perhaps another bug for gesture/multitouch support would be better.

Alberto - yes, others are working on this:

http://bitmath.org/code/multitouch
http://ubuntuforums.org/showthread.php?t=1334696

Good for us, it seems they are testing on Ubuntu. I am sure several people on this thread would be happy to help/contribute/test whatever they come up with.

Andy Whitcroft (apw) on 2010-04-09
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (10.2 KiB)

This bug was fixed in the package linux - 2.6.32-20.29

---------------
linux (2.6.32-20.29) lucid; urgency=low

  [ Andy Whitcroft ]

  * Revert "SAUCE: Use MODULE_IMPORT macro to tie intel_agp to i915"
    - LP: #542251
  * add Breaks: against hardy lvm2
    - LP: #528155

  [ Colin Watson ]

  * d-i -- enable udebs for generic-pae
    - LP: #160366

  [ Stefan Bader ]

  * [Config] Add xen netboot support
    - LP: #160366

  [ Takashi Iwai ]

  * (pre-stable): input: Support Clickpad devices in ClickZone mode
    - LP: #516329

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) Bluetooth: Fix sleeping function in RFCOMM within
    invalid context"
    - LP: #553837
  * Revert "(pre-stable) USB: fix usbfs regression"
    - LP: #553837
  * Revert "(pre-stable) softlockup: Stop spurious softlockup messages due
    to overflow"
    - LP: #553837
  * Revert "(pre-stable) drm/nouveau: report unknown connector state if lid
    closed"
    - LP: #553837
  * drivers/scsi/ses.c: eliminate double free
    - LP: #553837
  * decompress: fix new decompressor for PIC
    - LP: #553837
  * ARM: Fix decompressor's kernel size estimation for ROM=y
    - LP: #553837
  * MIPS: Cleanup forgotten label_module_alloc in tlbex.c
    - LP: #553837
  * tg3: Fix tg3_poll_controller() passing wrong pointer to tg3_interrupt()
    - LP: #553837
  * tg3: Fix 5906 transmit hangs
    - LP: #553837
  * ALSA: hda - Fix input source elements of secondary ADCs on Realtek
    - LP: #553837
  * ALSA: hda: enable MSI for Gateway M-6866
    - LP: #538918, #553837
  * timekeeping: Prevent oops when GENERIC_TIME=n
    - LP: #553837
  * Input: alps - add support for the touchpad on Toshiba Tecra A11-11L
    - LP: #553837
  * Input: i8042 - add ALDI/MEDION netbook E1222 to qurik reset table
    - LP: #553837
  * i2c-i801: Don't use the block buffer for I2C block writes
    - LP: #553837
  * ath5k: dont use external sleep clock in AP mode
    - LP: #553837
  * ath5k: fix setup for CAB queue
    - LP: #553837
  * ring-buffer: Move disabled check into preempt disable section
    - LP: #553837
  * function-graph: Init curr_ret_stack with ret_stack
    - LP: #553837
  * Bluetooth: Fix sleeping function in RFCOMM within invalid context
    - LP: #553837
  * tracing: Use same local variable when resetting the ring buffer
    - LP: #553837
  * tracing: Disable buffer switching when starting or stopping trace
    - LP: #553837
  * tracing: Do not record user stack trace from NMI context
    - LP: #553837
  * PCI: unconditionally clear AER uncorr status register during cleanup
    - LP: #553837
  * efifb: fix framebuffer handoff
    - LP: #553837
  * coredump: suppress uid comparison test if core output files are pipes
    - LP: #553837
  * V4L/DVB (13961): em28xx-dvb: fix memleak in dvb_fini()
    - LP: #553837
  * hrtimer: Tune hrtimer_interrupt hang logic
    - LP: #553837
  * x86, apic: Don't use logical-flat mode when CPU hotplug may exceed 8
    CPUs
    - LP: #553837
  * mvsas: add support for Adaptec ASC-1045/1405 SAS/SATA HBA
    - LP: #553837
  * pci: add support for 82576NS serdes to existing SR-IOV quirk
    - LP: #553837
  * sched: Mark boot-cpu active before smp_init()
    -...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Alberto Milone (albertomilone) wrote :

After a second look at the patch that I mentioned, I found that it's really a kernel patch not a patch for the X driver. I'm closing the task for the x driver.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Triaged → Invalid
assignee: Alberto Milone (albertomilone) → nobody
importance: Medium → Undecided
John Baptist (jepst79) wrote :

This bug also applies to the HP Mini 210-1010NR model.

Just to recap my own experience:

Out of the box, the actual "buttons" (which are physically part of the pad area) don't work. To effectuate a click, one has to tap on the pad. Right click is very hard, as one has to tap on the lower right corner of the pad; it usually takes me a few tries. Two-fingered scrolling does not work, but edge scrolling does.

This is my workaround: I discovered that by applying the following settings via synclient, I can achieve two-fingered scrolling, and a two-fingered tap will be interpreted as a right-click. (However, two-fingered scrolling is still a disabled option in gnome-mouse-mouse-properties.) This isn't a fix to this bug, but it might help people who are having trouble.

This command will do it:

synclient TapButton2=3 HorizTwoFingerScroll=1 VertTwoFingerScroll=1 EmulateTwoFingerMinZ=29 EmulateTwoFingerMinW=5

By the way, what is the "correct" way to apply these settings automatically at start up? Does one have to edit /usr/lib/X11/xorg.conf.d/* or is there a per-user way of applying these settings other than invoking synclient in .xinitrc? Any help would be appreciated.

Bernat (berarma) wrote :

"Out of the box, the actual "buttons" (which are physically part of the pad area) don't work. To effectuate a click, one has to tap on the pad. Right click is very hard, as one has to tap on the lower right corner of the pad; it usually takes me a few tries. Two-fingered scrolling does not work, but edge scrolling does."

Confirmed. At first it seems like they don't, you have to try at the very edge.

For Synaptics multitouch issues see bug 308191, bug 554980, bug 546697 and bug 413050.

In Maverick it still doesn't work properly. System doesn't even detect ot as Clickpad. I thought it would get better through the new Multitouch architecture but it doesn't seem like that.

Dana Goyette (danagoyette) wrote :

Hmm, I seem to have the exact opposite problem: it detects a non-ClickPad touchpad as a ClickPad, and thus breaks both my ability to use my real middle button, and my ability to click and drag with the left button.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/612591

Accepted into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Peter Magnusson (kmpm) wrote :

From what I can tell It works now in maverick. I don't have access to lucid on a affected system so I won't tag verification-done. That will have to be up to someone else.

Brad Figg (brad-figg) on 2011-01-18
tags: added: verification-done
removed: verification-needed
Bryce Harrington (bryce) on 2011-06-28
Changed in xorg-driver-synaptics:
status: New → Invalid
David Medberry (med) wrote :

Released Lucid always worked fine. Something changed in 10.04.3 and now a clickpad in Lucid has the same problems as Maverick, Natty, and Oneiric, namely bug #582809

affects: linux (Ubuntu) → ripspread
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers