Can't change Library name for DAAP Music sharing

Bug #894153 reported by Alex Moldovan on 2011-11-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Low
rhythmbox (Ubuntu)
Low
Canonical Desktop Team

Bug Description

To reproduce:
Open Rhythmbox, go to Edit > Plugins, click on DAAP Music Sharing > Preferences and try to change the Library name.
When I have multiple computers in my network, having the same username I don't know which library to open because they will all have the same name:
$FULL-USERNAME's Music.

I know there are functions in the ./plugins/daap/rb-daap-sharing.c file, but I wasn't able to see if the signal that changes the share name gets triggered or not.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: rhythmbox-plugins 2.90.1~20110908-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Wed Nov 23 15:52:28 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110908)
SourcePackage: rhythmbox
UpgradeStatus: No upgrade log present (probably fresh install)

Alex Moldovan (alexmoldovan) wrote :
description: updated
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
komputes (komputes) wrote :

This worked in rhythmbox 0.12.8-0ubuntu7 (Lucid). This is therefore a regression (most likely in the rhythmbox-plugins package).

Alex Moldovan (alexmoldovan) wrote :
Changed in rhythmbox:
importance: Unknown → Low
status: Unknown → Fix Released

I presume this will be picked up with a new upstream release into Ubuntu

Changed in rhythmbox (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
importance: Undecided → Low
Martin Pitt (pitti) wrote :

Fixed upstream.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

the commit is http://git.gnome.org/browse/rhythmbox/commit/?id=8bc2fc3f436591fe557a5c27418089e8d59e0658

we will update our snapshot using ricotz's ppa version

Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 2.90.1~20111126.89c872b0-0ubuntu1

---------------
rhythmbox (2.90.1~20111126.89c872b0-0ubuntu1) precise; urgency=low

  * Upload the new version to Ubuntu, should solve those issues:
    - the lack of rhythmbox-client command (lp: #875064)
    - the music sharing preferences dialog (lp: #894153)
    - several segfaults (lp: #859195, #814614)
  * debian/control.in:
    - let the rhythmbox gir depends on gir1.2-peas-1.0 (lp: #874973)

  [ Rico Tzschichholz ]
  * New upstream git snapshot
 -- Sebastien Bacher <email address hidden> Mon, 05 Dec 2011 19:31:23 +0100

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.