[MTP] ugly behavior if device is full

Bug #393182 reported by Someone561 on 2009-06-28
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
Rhythmbox
Expired
Medium
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

Rhythmbox handles a full MTP device very ugly.
Steps to reproduce:
1) Enable MTP-Plugin
2) Copy files to MTP-Device until the device is full
Rhythembox open now the Message:
Media player device error
LIBMTP_Send_File_From_File_Descriptor(): all device storage is full or corrupt
(attached as Image)

This Message is not come one time. This message comes for every file Rhythembox tries to copy and the user need to click close to every one.

Proposed Solution:
Show only one error message, for all the files once.
& Abort operations on error.

ProblemType: Bug
Architecture: amd64
Date: Sun Jun 28 19:21:59 2009
DistroRelease: Ubuntu 9.10
Package: rhythmbox 0.12.2-0ubuntu2
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-10.12-generic
SourcePackage: rhythmbox
Uname: Linux 2.6.30-10-generic x86_64

Someone561 (someone561) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Changed in rhythmbox:
status: Unknown → Invalid
Vish (vish) wrote :

This seems to be a genuine bug, Not a papercut.

Thank you for bringing this bug to our attention. Please answer these questions:
1: Does this problem exist in Karmic? Kindly test this in karmic ,Papercuts are minor issues that exist in Karmic
2: Also, I dont see a easy/quick fix for this , Why do you think this is a papercut?
3: What is the papercut solution you propose?

A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.

For further info about papercuts criteria , pls read > https://wiki.ubuntu.com/PaperCut

Don't worry though, This bug has been marked as "incomplete" ONLY in the papercuts project.

Changed in hundredpapercuts:
status: New → Incomplete
Changed in rhythmbox:
status: Invalid → Unknown
Changed in rhythmbox:
status: Unknown → New
Someone561 (someone561) wrote :

1. Yes, I tested in Karmic
2. I think, checking for this error and then aborting and not try to copy the remaining files is not very hard.
3. Show only one error message, not 60 if you try to copy 60 files.

Changed in rhythmbox (Ubuntu):
status: New → Triaged
Vish (vish) on 2009-07-01
Changed in hundredpapercuts:
status: Incomplete → Confirmed
description: updated
Vish (vish) on 2009-07-01
description: updated
Someone561 (someone561) wrote :

I have now tested this with a apple IPod. There is the same behavior. Only the message is a other:
Error transferring track
Could not write to resource.

But I get also a message for every file rhythmbox could not copy.

Vish (vish) on 2010-01-23
Changed in hundredpapercuts:
importance: Undecided → Low
Lars Kumbier (derlars) wrote :

confirmed in Jaunty

Changed in rhythmbox:
importance: Unknown → Medium
Vish (vish) wrote :

 - In Ubuntu 11.04, Rhythmbox will no longer be part of the default install. Hence not a papercut.
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.
Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

Changed in hundredpapercuts:
status: Confirmed → Invalid
Chris Wilson (notgary) wrote :

Reopening as part of a review of closed paper cuts.

Changed in hundredpapercuts:
status: Invalid → New
Chris Wilson (notgary) on 2013-05-27
Changed in hundredpapercuts:
milestone: none → papercuts-s-rhythmbox
Changed in rhythmbox:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.