The Rhythmbox Music Management Application

Support OggKate to display song lyrics

Reported by Kẏra on 2009-03-29
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Amarok
Confirmed
Wishlist
Banshee
Fix Released
Wishlist
Miro
New
Undecided
Unassigned
Rhythmbox
New
Wishlist
Songbird
Confirmed
High
Totem
Incomplete
Undecided
Unassigned
VLC media player
Confirmed
Wishlist
Rémi Denis-Courmont

Bug Description

Display lyrics using OggKate http://wiki.xiph.org/index.php/OggKate for karaoke mode

bug 1106607 is to remove vocals from audio tracks for "karaoke mode"

Myriam Schweingruber (myriam) wrote :

This is not a bug but a wish that should go upstream IMHO.

Changed in amarok (Ubuntu):
status: New → Invalid
Changed in amarok:
importance: Undecided → Wishlist
status: New → Incomplete
Aren Olson (reacocard) on 2009-03-29
Changed in exaile:
importance: Undecided → Wishlist
status: New → Incomplete
Johannes Sasongko (sjohannes) wrote :

This is probably trivial to add as a plugin to an existing app that supports inserting a gst element in the pipeline. The voice removal part can be done with the audiokaraoke gst element [1], while lyrics can come from one of the thousands of lyrics sites out there.

[1] http://gstreamer.freedesktop.org/data/doc/gstreamer/head/gst-plugins-good-plugins/html/gst-plugins-good-plugins-audiokaraoke.html

Changed in exaile:
status: New → Invalid
Changed in rhythmbox (Ubuntu):
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: New → Triaged
Changed in rhythmbox:
importance: Undecided → Unknown
status: New → Unknown
Changed in rhythmbox:
status: Unknown → New
Changed in totem (Ubuntu):
importance: Undecided → Wishlist
Pedro Villavicencio (pedro) wrote :

Totem bug should be send upstream directly at bugzilla.gnome.org by someone interested on the feature and same for the gstreamer tasks. thanks.

Changed in banshee (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Chow Loong Jin (hyperair) wrote :

Forwarded upstream.

Changed in banshee:
importance: Undecided → Unknown
status: New → Unknown
Changed in banshee:
status: Unknown → New
Changed in banshee (Ubuntu):
status: Confirmed → Triaged
Kẏra (kxra) on 2009-06-14
description: updated
summary: - Add Karaoke Mode
+ Add Karaoke Mode to remove vocals from audio

So how can this plugin be implemented in media players (shouldn't this bug
be used)? Also, does audiokaraoke sue the same method Rockbox does?

On Mon, Mar 30, 2009 at 00:34, Johannes Sasongko <email address hidden> wrote:

> This is probably trivial to add as a plugin to an existing app that
> supports inserting a gst element in the pipeline. The voice removal part
> can be done with the audiokaraoke gst element [1], while lyrics can come
> from one of the thousands of lyrics sites out there.
>
> [1] http://gstreamer.freedesktop.org/data/doc/gstreamer/head/gst-
> plugins-good-plugins/html/gst-plugins-good-plugins-audiokaraoke.html<http://gstreamer.freedesktop.org/data/doc/gstreamer/head/gst-%0Aplugins-good-plugins/html/gst-plugins-good-plugins-audiokaraoke.html>
>
> ** Changed in: exaile (Ubuntu)
> Status: New => Invalid
>
> --
> Add Karaoke Mode
> https://bugs.launchpad.net/bugs/350781
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
http://www.google.com/profiles/danny.piccirillo

Kẏra (kxra) on 2009-06-14
Changed in gstreamer:
status: New → Invalid
Andrew (and471) on 2009-08-26
Changed in totem:
status: New → Incomplete

sSongbird is not in Ubuntu at this time so it is unsupported however upstream might like to know

Changed in songbird:
status: New → Invalid
Kẏra (kxra) wrote :

That doesn't make the bug invalid. It isn't even filed in Ubuntu. It just needs to be forwarded upstream

Changed in songbird:
status: Invalid → New

On 08/27/2009 12:35 PM, Danny Piccirillo wrote:
> That doesn't make the bug invalid. It isn't even filed in Ubuntu. It
> just needs to be forwarded upstream
>
> ** Changed in: songbird
> Status: Invalid => New
>
It is invalid since the package is not in repos. We only
support packages in offical repos. If you have a bug in
songbird you should file bug upstream not with us. Since no
one looked for it upstream or filed it. Once you file it
upstream drop the link to it here and we will see if we are
able to track the bug.

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

"How can i get lost, if i have no where to go"
    -- Metallica from Unforgiven III

Changed in songbird:
status: New → Invalid

Launchpad isn't Ubuntu-only. I filed the bug under the songbird project, not the songbird package in Ubuntu. Well, here it is from the songbird website anyways.

Changed in songbird:
importance: Undecided → Unknown
status: Invalid → Unknown
Kẏra (kxra) on 2009-08-28
summary: - Add Karaoke Mode to remove vocals from audio
+ Add Karaoke Mode to remove vocals from audio (and display lyrics?)
Changed in songbird:
status: Unknown → New
Kẏra (kxra) on 2009-08-29
Changed in songbird:
status: New → Unknown
Changed in songbird:
status: Unknown → Confirmed

On 08/28/2009 12:32 PM, Danny Piccirillo wrote:
> Launchpad isn't Ubuntu-only. I filed the bug under the songbird project,
> not the songbird package in Ubuntu. Well, here it is from the songbird
> website anyways.
>
> ** Bug watch added: Songbird Bugzilla #17724
> http://bugzilla.songbirdnest.com/show_bug.cgi?id=17724
>
> ** Changed in: songbird
> Importance: Undecided => Unknown
>
> ** Changed in: songbird
> Status: Invalid => Unknown
>
> ** Changed in: songbird
> Remote watch: None => Songbird Bugzilla #17724
>
I never stated it was Ubuntu only. You filed the songbird
package in the first place against Ubuntu.

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

"How can i get lost, if i have no where to go"
    -- Metallica from Unforgiven III

Kẏra (kxra) wrote :

On Mon, Aug 31, 2009 at 09:00, John Vivirito <email address hidden> wrote:

> On 08/28/2009 12:32 PM, Danny Piccirillo wrote:
> > Launchpad isn't Ubuntu-only. I filed the bug under the songbird project,
> > not the songbird package in Ubuntu. Well, here it is from the songbird
> > website anyways.
> >
> > ** Bug watch added: Songbird Bugzilla #17724
> > http://bugzilla.songbirdnest.com/show_bug.cgi?id=17724
> >
> > ** Changed in: songbird
> > Importance: Undecided => Unknown
> >
> > ** Changed in: songbird
> > Status: Invalid => Unknown
> >
> > ** Changed in: songbird
> > Remote watch: None => Songbird Bugzilla #17724
> >
> I never stated it was Ubuntu only. You filed the songbird
> package in the first place against Ubuntu.
>
>
That would be impossible because like you said songbird isn't even in Ubuntu
so launchpad doesn't have a songbird package in ubuntu for me to report it
against. It can only be listed against the songbird project.

> --
> Sincerely Yours,
> John Vivirito
>
> https://launchpad.net/~gnomefreak
> https://wiki.ubuntu.com/JohnVivirito
> Linux User# 414246
>
> "How can i get lost, if i have no where to go"
> -- Metallica from Unforgiven III
>
> --
> Add Karaoke Mode to remove vocals from audio (and display lyrics?)
> https://bugs.launchpad.net/bugs/350781
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
☮♥Ⓐ - http://www.google.com/profiles/danny.piccirillo

John Vivirito (gnomefreak) wrote :

On 08/31/2009 09:19 AM, Danny Piccirillo wrote:
> On Mon, Aug 31, 2009 at 09:00, John Vivirito <email address hidden>
> wrote:
>
>> On 08/28/2009 12:32 PM, Danny Piccirillo wrote:
>>> Launchpad isn't Ubuntu-only. I filed the bug under the songbird project,
>>> not the songbird package in Ubuntu. Well, here it is from the songbird
>>> website anyways.
>>>
>>> ** Bug watch added: Songbird Bugzilla #17724
>>> http://bugzilla.songbirdnest.com/show_bug.cgi?id=17724
>>>
>>> ** Changed in: songbird
>>> Importance: Undecided => Unknown
>>>
>>> ** Changed in: songbird
>>> Status: Invalid => Unknown
>>>
>>> ** Changed in: songbird
>>> Remote watch: None => Songbird Bugzilla #17724
>>>
>> I never stated it was Ubuntu only. You filed the songbird
>> package in the first place against Ubuntu.
>>
>>
> That would be impossible because like you said songbird isn't even in Ubuntu
> so launchpad doesn't have a songbird package in ubuntu for me to report it
> against. It can only be listed against the songbird project.
>
>
>> --
>> Sincerely Yours,
>> John Vivirito
>>
>> https://launchpad.net/~gnomefreak
>> https://wiki.ubuntu.com/JohnVivirito
>> Linux User# 414246
>>
>> "How can i get lost, if i have no where to go"
>> -- Metallica from Unforgiven III
>>
>> --
>> Add Karaoke Mode to remove vocals from audio (and display lyrics?)
>> https://bugs.launchpad.net/bugs/350781
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>
>
Sorry i thought the songbird task showed Ubuntu changes menu

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

"How can i get lost, if i have no where to go"
    -- Metallica from Unforgiven III

Added a simple plugin to Exaile using the audiokaraoke element.

Changed in exaile:
assignee: nobody → Johannes Sasongko (sjohannes)
milestone: none → 0.3.1
status: Incomplete → Fix Committed
Changed in vlc:
importance: Undecided → Wishlist
status: New → Confirmed
Changed in vlc (Ubuntu):
status: New → Confirmed
Aren Olson (reacocard) on 2010-03-16
Changed in exaile:
status: Fix Committed → Fix Released
Myriam Schweingruber (myriam) wrote :

Removing vocals from the tracks is out of Amarok's scope, this needs to be done by the phonon backend in use

Changed in amarok:
importance: Wishlist → Unknown
status: Incomplete → Unknown

Thank you for reporting this bug.

Regarding VLC, this looks like a wishlist. Should be marked as such.

Changed in vlc (Ubuntu):
status: Confirmed → Incomplete
Changed in rhythmbox:
importance: Unknown → Wishlist
Changed in banshee:
importance: Unknown → Wishlist
Laszlo Pandy (laszlok) on 2010-09-18
Changed in jokosher:
importance: Undecided → Wishlist
status: New → Triaged
Changed in jokosher (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Vish (vish) wrote :

Reverting status.

Changed in vlc (Ubuntu):
importance: Undecided → Wishlist
status: Incomplete → Confirmed
Changed in amarok:
status: Unknown → Confirmed
Changed in songbird:
importance: Unknown → High
Changed in banshee:
status: New → Fix Released
Changed in amarok:
importance: Unknown → Wishlist
madbiologist (me-again) wrote :

I'm not sure if it is relevant to the kate lyrics part of this bug, but GStreamer Base Plug-ins 0.10.32 has implemented packet duration query for kate streams within ogg - see http://gstreamer.freedesktop.org/releases/gst-plugins-base/0.10.32.html and https://bugzilla.gnome.org/show_bug.cgi?id=637519

Changed in vlc:
importance: Wishlist → Unknown
status: Confirmed → Unknown
Changed in vlc:
importance: Unknown → Undecided
status: Unknown → New
assignee: nobody → Rémi Denis-Courmont (rdenis)
status: New → Fix Released
importance: Undecided → Wishlist
Kẏra (kxra) on 2012-01-07
summary: - Add Karaoke Mode to remove vocals from audio (and display lyrics?)
+ Add Karaoke Mode to remove vocals from audio (and display lyrics)
description: updated

A karaoke extension is now available in banshee-extension-karaoke.

affects: banshee (Ubuntu) → banshee-community-extensions (Ubuntu)
Changed in banshee-community-extensions (Ubuntu):
status: Triaged → Fix Released
Rémi Denis-Courmont (rdenis) wrote :

Fixed in VLC 2.0.0.

Changed in vlc (Ubuntu):
status: Confirmed → Fix Released
Kẏra (kxra) on 2012-03-19
summary: - Add Karaoke Mode to remove vocals from audio (and display lyrics)
+ Support OggKate to display lyrics in "Karaoke Mode" (no vocals)
description: updated
Kẏra (kxra) on 2013-01-27
no longer affects: vlc (Ubuntu)
no longer affects: totem (Ubuntu)
no longer affects: rhythmbox (Ubuntu)
no longer affects: amarok (Ubuntu)
description: updated
Kẏra (kxra) on 2013-01-27
no longer affects: exaile
no longer affects: gstreamer
no longer affects: banshee-community-extensions (Ubuntu)
no longer affects: exaile (Ubuntu)
no longer affects: jokosher (Ubuntu)
Kẏra (kxra) on 2013-01-27
description: updated
summary: - Support OggKate to display lyrics in "Karaoke Mode" (no vocals)
+ Support OggKate to display song lyrics
no longer affects: jokosher
Kẏra (kxra) on 2014-03-18
Changed in vlc:
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.