rhythmbox crashed with SIGSEGV in PyString_FromString()

Bug #979780 reported by alexixor on 2012-04-12
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu One for Rhythmbox
rhythmbox (Ubuntu)

Bug Description

I was browsing the ubuntu music store and the I wnt to the radio stations in rythmbox to lister to so online radio. I saw 100% cpu, rythmbox did not respond. Then the crash dialog appeared.

Rythmbox did not crash though. I clicked again on the station and it started paying.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: rhythmbox 2.96-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu2
Architecture: amd64
Date: Thu Apr 12 12:20:28 2012
ExecutablePath: /usr/bin/rhythmbox
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
ProcCmdline: rhythmbox
 PATH=(custom, no user)
 Segfault happened at: 0x7f8513ec6361: movdqu (%rdi),%xmm1
 PC (0x7f8513ec6361) ok
 source "(%rdi)" (0x00000089) not located in a known VMA region (needed readable region)!
 destination "%xmm1" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: rhythmbox
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 PyString_FromString () from /usr/lib/libpython2.7.so.1.0
 ?? () from /usr/lib/python2.7/dist-packages/gi/_gi.so
 PyEval_EvalFrameEx () from /usr/lib/libpython2.7.so.1.0
 PyEval_EvalCodeEx () from /usr/lib/libpython2.7.so.1.0
Title: rhythmbox crashed with SIGSEGV in PyString_FromString()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #926618, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
visibility: private → public
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Hendrik Knackstedt (hennekn) wrote :

Same happend to me when playing a song preview in Ubuntu One Music store and then trying to play a preview of another song. This happens every time I do this so it's easily reproducable.

Apport marked this bug as a duplicate of a private bug, so please make bug #926618 public, so it can be solved. This is a serious problem with the Ubuntu One music store. For now, I am removing duplicate status.

Hendrik Knackstedt (hennekn) wrote :

Well, Rhythmbox actually crashes in my case though!

Hendrik Knackstedt (hennekn) wrote :

There is another crash related to this one. See bug 972510.

Dave Morley (davmor2) wrote :

Unable to reproduce on prcise.
I have tried playing multiple tracks and switching to radio from a playing track and to normal music from a playing track.

However due to the fact that there is more than one user reporting issue I will set to confirmed and direct to the relivant team.

Changed in rhythmbox-ubuntuone:
status: New → Confirmed
assignee: nobody → Ubuntu One Client Engineering team (ubuntuone-client-engineering)
Hendrik Knackstedt (hennekn) wrote :

This crash occurs for me in Precise every (!) time I am trying to play a preview or sometimes even while browsing the Music Store.

Stefan Taferner (taferner) wrote :

I had this problem too in the past.

However, doing a quick test in quantal I was unable to trigger a crash. I randomly switched around in the Ubuntu One music store playing previews and switched to listening radio stations and back to the music store.

This triggered a crash before, but it works now for me.

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Incomplete
Changed in rhythmbox-ubuntuone:
status: Confirmed → Invalid
dobey (dobey) on 2014-04-13
Changed in rhythmbox-ubuntuone:
assignee: Ubuntu One Client Engineering team (ubuntuone-client-engineering) → nobody
Launchpad Janitor (janitor) wrote :

[Expired for rhythmbox (Ubuntu) because there has been no activity for 60 days.]

Changed in rhythmbox (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers