Ubuntu One plugin has problems when being enable/disabled

Bug #951425 reported by Aurélien RIVIERE on 2012-03-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu One for Rhythmbox
Status tracked in Trunk
Stable-3-0
High
dobey
Trunk
High
dobey
rhythmbox-ubuntuone (Ubuntu)
High
dobey
Precise
High
dobey

Bug Description

ubuntu@precise:~$ uname -a && lsb_release -a
Linux precise 3.2.0-18-generic-pae #28-Ubuntu SMP Fri Mar 2 22:11:12 UTC 2012 i686 i686 i386 GNU/Linux
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu precise (development branch)
Release: 12.04
Codename: precise

Last RhythmBox release of the official precise repositories

open the plugin list
while 1:
   enable Ubuntu One plugin
   disable Ubuntu One plugin

Every time U1 plugin is enabled, a new U1 icon comes in the sidebar.
When disabled, nothing happens.

Related branches

Daniel Lawrence (dannyla) wrote :

Was able to replicate the issue with the following steps:

* Start rhythmbox
* Edit
* Plugins
* Scroll down to the button of the plugin list to "Ubuntu One"
* Clicking the check box to enable and disable
* Clicking the check box to enable and disable
* Clicking the check box to enable and disable

The button appears to adds extra "Ubuntu One" to the side UI under the "Stores" header, with only the first "Ubuntu One" Store accessible and working as expected.

This looks like it is only a bug with removing the "Ubuntu One" from the side UI

Daniel Lawrence (dannyla) wrote :

added extra project "rhythmbox-ubuntuone" to the affected projects.

affects: rhythmbox (Ubuntu) → rhythmbox-ubuntuone
Daniel Lawrence (dannyla) wrote :

able to replicate issue on same release, attached screenshot to verify

Changed in rhythmbox-ubuntuone:
status: New → Confirmed
description: updated
dobey (dobey) on 2012-03-15
Changed in rhythmbox-ubuntuone (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-2
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → High
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox-ubuntuone - 2.99.91-0ubuntu1

---------------
rhythmbox-ubuntuone (2.99.91-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Fix handling of plug-in disabling/enabling (LP: #951425)
    - Avoid creating duplicate tracks in the library (LP: #934206)
 -- Rodney Dawes <email address hidden> Tue, 20 Mar 2012 18:05:25 -0400

Changed in rhythmbox-ubuntuone (Ubuntu Precise):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers