The music store should start the syncdaemon

Bug #544563 reported by Alex Eftimie on 2010-03-22
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ubuntu One for Rhythmbox
High
Rodrigo Moya

Bug Description

Currently, there is no easy way from the u1musicstore in rhythmbox to find if the user is connected or not to u1.

One needs to get in a terminal and issue a: `u1sdtool -s'.

Maybe putting the user name in the header, or, if this adds unneeded complexity, putting a status page in module config will solve this problem.

Related branches

Stuart Langridge (sil) wrote :

Using the music store should automatically connect the syncdaemon. This is being worked on.

Changed in rhythmbox-ubuntuone-music-store:
assignee: nobody → Rodrigo Moya (rodrigo-moya)
status: New → Confirmed
importance: Undecided → Medium
importance: Medium → High
Stuart Langridge (sil) on 2010-03-23
summary: - Add a way to check u1 account status from rhythmbox
+ The music store should start the syncdaemon
Rodrigo Moya (rodrigo-moya) wrote :

The music store widget connects the syncdaemon as soon as there are OAuth tokens, so this might be again the invalid oauth tokens problem. Could someone that doesn't get the syncdaemon to connect run rhythmbox on the command line and paste the output from the terminal here?

Apart from that, I'm adding now code to listen to status changes, so that we reconnect again if it gets disconnected while running the music store

Changed in rhythmbox-ubuntuone-music-store:
status: Confirmed → In Progress
Rodrigo Moya (rodrigo-moya) wrote :

Merged to trunk, will be released tomorrow when we do a new libu1 release

Changed in rhythmbox-ubuntuone-music-store:
status: In Progress → Fix Committed
Changed in rhythmbox-ubuntuone-music-store:
status: Fix Committed → Fix Released
oldos2er (oldos2er) wrote :
Download full text (15.2 KiB)

I am still experiencing this bug. Running 10.04 beta2, updated as of 10 Apr 2010. I purchased music from the Ubuntu One Music Store via Rhythmbox 0.12.8 with Ubuntu One Music Store plugin enabled. It's been about 15 hours since my purchase; nothing's shown up in Ubuntu One or my local ~/Music folder.

Here is output from "rhythmbox" run in terminal:

ann@ubuntu:~$ rhythmbox

(rhythmbox:512): Rhythmbox-WARNING **: source 0x1784340 has no group
** (rhythmbox:512): DEBUG: Loading the real store page

liboauth: data to sign='GET&https%3A%2F%2Fone.ubuntu.com%2Fmusic%2Flogin&oauth_callback%3DNone%26oauth_consumer_key%3Dubuntuone%26oauth_nonce%3D_I9Y6uzQB2SFrs4%26oauth_signature_method%3DHMAC-SHA1%26oauth_timestamp%3D1270928517%26oauth_token%3D9H5nSCpJqJSvkV4lZ21W%26oauth_verifier%3DNone%26oauth_version%3D1.0'

liboauth: key='hammertime&p50JT2hhbgJR23R7WzCbfcCrRfSzPZBXgdPc4xKLX0pWqsBHLQ472GCLKNXhFdr23GKlFvmtJXDCNZt5'

** (rhythmbox:512): DEBUG: navigation requested to https://one.ubuntu.com/music/login?oauth_callback=None&oauth_consumer_key=ubuntuone&oauth_nonce=_I9Y6uzQB2SFrs4&oauth_signature_method=HMAC-SHA1&oauth_timestamp=1270928517&oauth_token=9H5nSCpJqJSvkV4lZ21W&oauth_verifier=None&oauth_version=1.0&oauth_signature=pHNZhq5k75GZ8vks%2B68%2BP1CsNCY%3D

(rhythmbox:512): GLib-GObject-WARNING **: instance of invalid non-instantiatable type `(null)'

(rhythmbox:512): GLib-GObject-CRITICAL **: g_signal_handlers_unblock_matched: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(rhythmbox:512): GLib-GObject-WARNING **: instance of invalid non-instantiatable type `(null)'

(rhythmbox:512): GLib-GObject-CRITICAL **: g_signal_handlers_unblock_matched: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(rhythmbox:512): Rhythmbox-CRITICAL **: rb_property_view_set_selection: assertion `RB_IS_PROPERTY_VIEW (view)' failed

(rhythmbox:512): GLib-GObject-WARNING **: instance of invalid non-instantiatable type `<invalid>'

(rhythmbox:512): GLib-GObject-CRITICAL **: g_signal_handlers_unblock_matched: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(rhythmbox:512): GLib-GObject-WARNING **: instance of invalid non-instantiatable type `<invalid>'

(rhythmbox:512): GLib-GObject-CRITICAL **: g_signal_handlers_unblock_matched: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(rhythmbox:512): Rhythmbox-CRITICAL **: rb_property_view_set_selection: assertion `RB_IS_PROPERTY_VIEW (view)' failed

(rhythmbox:512): GLib-GObject-WARNING **: instance with invalid (NULL) class pointer

(rhythmbox:512): GLib-GObject-CRITICAL **: g_signal_handlers_unblock_matched: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(rhythmbox:512): GLib-GObject-WARNING **: instance with invalid (NULL) class pointer

(rhythmbox:512): GLib-GObject-CRITICAL **: g_signal_handlers_unblock_matched: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(rhythmbox:512): Rhythmbox-CRITICAL **: rb_property_view_set_selection: assertion `RB_IS_PROPERTY_VIEW (view)' failed
** (rhythmbox:512): DEBUG: navigation requested to http://stores.7digital.com/user/partnerLogin.aspx?shop=480&returnUrl=http%3A%2F%2Fstores.7digital.com%2Fdefault.aspx%3Fshop%3D480%26partner%3D983&oauth_nonce=76794400&oauth_...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions