error compiling reztorrent

Bug #390930 reported by Charles Kerr on 2009-06-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
RezTorrent
Critical
Steve Dodier-Lazaro

Bug Description

When attempting to compile reztorrent, I get a handful of link errors similar to this:

> /tmp/ccZiJcZQ.o: In function `init_dbus_server':
> /home/charles/src/reztorrent/cli/dbus/dbus-server.c:153: multiple definition of `init_dbus_server'
> /tmp/ccThxu5e.o:/home/charles/src/reztorrent/cli/dbus/dbus_server.c:161: first defined here

Notice that the first file is dbus-server.c (with a hyphen) and the second is dbus_server.c (with an underscore).

All I did was bzr branch lp:reztorrent; cd reztorrent/cli/; make

Charles Kerr (charlesk) wrote :
Steve Dodier-Lazaro (sidi) wrote :

Hello,

Thank you for your interest in RezTorrent. Unfortunately I didn't update the bzr version for a while because I can't push to a bzr repository due to my network's restrictions.

I'll upload new code friday or saturday (code that compiles with gcc 4.3 on several machines, and that uses autotools, because we were actually building without dbus when I pushed the current code).

By the meanwhile, you can clone this git repository which has the latest stable code (probably the code of the 0.1 release) : http://cgit.noname-land.org/torrent

Changed in reztorrent:
assignee: nobody → Steve Dodier (sidi)
importance: Undecided → Critical
milestone: none → release
status: New → Fix Committed
Charles Kerr (charlesk) wrote :

Thank you for the update. Unfortunately it's now failing in a separate place.
It appears to be a problem with linking one of the third-party libraries.

Attached is a full log of a bzr checkout + build.

Steps to reproduce:
$ bzr branch lp:reztorrent
$ cd reztorrent/cli
$ ./autogen.sh

Changed in reztorrent:
status: Fix Committed → New
Charles Kerr (charlesk) wrote :
Steve Dodier-Lazaro (sidi) wrote :

Fixed in revision 7.

Changed in reztorrent:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers