select() : bad file descriptor in torrent_process_receive()

Bug #362823 reported by Steve Dodier-Lazaro on 2009-04-17
2
Affects Status Importance Assigned to Milestone
RezTorrent
High
RezTeam Developers

Bug Description

File torrents_manager.c
Function torrent_process_receive()
Receiving select() : bad file descriptor

Faulty function : update_peers_in_select. it seems some peers have an invalid yet positive socket, they probably disconnected without us to take notice of it.

Steve Dodier-Lazaro (sidi) wrote :
Changed in reztorrent:
assignee: nobody → elentir-b
importance: Undecided → High
milestone: none → release
status: New → Triaged
Steve Dodier-Lazaro (sidi) wrote :

Seems fixed. That was coming from connections being dropped but torrents not removed from the list.

Changed in reztorrent:
assignee: elentir-b → sidi
status: Triaged → Fix Committed
Steve Dodier-Lazaro (sidi) wrote :

Happening again after the regression to previous code due to the memory corruption problem.

Changed in reztorrent:
assignee: sidi → rezteam
status: Fix Committed → Incomplete
Steve Dodier-Lazaro (sidi) wrote :

Forgot a FD_CLR on bad sockets, or a FD_ZERO before regening the FD_SET

Changed in reztorrent:
status: Incomplete → Fix Committed
Changed in reztorrent:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments