unpack-package (and possibly other commands) fail with import error

Bug #2072665 reported by Guillermo Gonzalez
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
review-tools
Fix Committed
Medium
Jorge Sancho Larraz

Bug Description

After updating review-tools in dashboard/sca, we are seeing:

Extracting the package failed:

    Traceback (most recent call last):
      File "/srv/sca-worker/code/branches/click-reviewers-tools/bin/unpack-package", line 15, in <module>
        common.unpack_pkg(pkg, dir)
    AttributeError: module 'reviewtools.common' has no attribute 'unpack_pkg'

I think the move of functions out of reviewtools/commons.py is the cause: https://git.launchpad.net/review-tools/commit/?id=97ce21fc1803c0e84e77f866486944fb8e745ddf

This might affect other commands in bin/

Changed in review-tools:
status: New → Confirmed
assignee: nobody → Jorge Sancho Larraz (jslarraz)
importance: Undecided → Medium
Revision history for this message
Jorge Sancho Larraz (jslarraz) wrote :
Revision history for this message
Jorge Sancho Larraz (jslarraz) wrote :
Changed in review-tools:
status: Confirmed → Fix Released
status: Fix Released → Fix Committed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.