Changing language requires restart, but no indication is given

Bug #592796 reported by Daniel Kulesz
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
RevAger
Fix Released
Undecided
Unassigned
1.3
New
Medium
Unassigned

Bug Description

Version tested: RevAger trunk, Revision 49
Environment: Windows XP SP3, 32bit, Java 1.6.0.17-b04,

Steps to reproduce:
- delete your revager settings directory, start RevAger.
- click on the language flag
- choose the desired language and click the confirm button.

Expected behavior:
- after selecting the language, RevAger instantly changes the language or offers the option to restart itself to make the changes take effect.

Actual behavior:
- clicking the language button in the selection gives almost no visual feedback.
- clicking the confirm dialog does not close the popup window
- the language is not switched, and no indication why this is the case is given - the user has to "guess", that a restart of the application might be required.

Another minor usability flaw: Why do we need this confirm button for changing the language actually?

Tags: 1.4 usability
Daniel Kulesz (kuleszdl)
tags: added: usability
Revision history for this message
Johannes Wettinger (jojow) wrote :

That's a candidate for 1.3.1 as well. ;)

Revision history for this message
Davide Casciato (casciade) wrote :

Very good idea, Daniel. We should implement this functionality in any case :)

In my opinion the confirm button in the language popup is necessary because of the usability! Imagine the popup without the possibility to confirm. Omitting the confirm button would imply the closing of the popup after your language selection. Wouldn't this be a strange behaviour? We have to provide a button to close the popup anyway.

But usability also depends on the individual user and is therefore a matter of taste ;)

Revision history for this message
Daniel Kulesz (kuleszdl) wrote :

I agree, we really need a "cancel" button for the language switching dialog.

But when the user clicks on the language flag, he already expresses his intent to change the language - why should he confirm this action once more? Apart from that, the action will nevertheless not take effect immediately, but after application restart.

Well, maybe our usability expert Holger can be provide us with the killer-hint on this issue.

tags: added: 1.4
Changed in revager:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers