Application crashing upon entering review meeting

Bug #894464 reported by Daniel Kulesz on 2011-11-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
RevAger
Critical
Johannes Wettinger

Bug Description

(observed in RevAger 1.4.1 during production use on Windows 7)

Reproduction steps:
- use an external Beamer, using RevAger on one of the screens
- start RevAger
- Plan meeting
- Start meeting, add all findings etc.
- Fill in all information
- Exit Meeting
- Save Review
- Re-enter protocol mode

The application hangs with the "hourglass" from there on. After restarting RevAger it is remarkable, that the "Comments about the review" are lost, although the review was saved successfully before. (The reviewers submitted the ".rev"-file to me. I can't post it here since it's confidential...)

Daniel Kulesz (kuleszdl) on 2011-11-24
Changed in revager:
importance: Undecided → Critical
assignee: nobody → Johannes Wettinger (jojow)
Daniel Kulesz (kuleszdl) wrote :

Update: I was able to reproduce the bug on Windows XP with a single output. Thanks a lot to the review team for providing me with the file.

The bug only occurs after opening the Review, entering the Protocol, exiting it and *re-entering* it. I tried several reproductions and probably I found the most important hint: The bug seems to be reproducible only if (but in this case really deterministic) when the Protocol was exited from the "Comments and recommendation" tab! Exiting the protocol from any other tab does not lead to this crash.

Daniel Kulesz (kuleszdl) wrote :

Re-tried with RevAger 1.4, but I was unable to reproduce the bug there. It seems, only 1.4.1 is affected so far.

Davide Casciato (casciade) wrote :

Thank you Daniel for your bug report. Johannes and me will fix this problem as soon as possible.

Changed in revager:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers