broken links after migration and upgrade

Bug #1454926 reported by Michael Foley on 2015-05-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Insights
Undecided
Unassigned

Bug Description

After migrating and upgrading insights.ubuntu.com wordpress blog I was seeing some broken images so I ran linkchecker-gui against the site and fixed up all the wp-content/uploads/ links I found and a few other links that were obvious fixes.

I could not figure how to fix links of the form /news, /topic, /whitepaper, /category, etc. These links seem to be some kind of redirect that is no longer working after the migration.

I have attached the linkchecker output with a list of broken URLs.
Note: I set linkchecker to a depth of 4 and set it to ignore some link patters to avoid excessive false positives.
Ignored links were:
mailto
/topic/feed
/?p=
css
pdf

Michael Foley (foli) wrote :
Michael Foley (foli) wrote :

I have found a fix for this and have corrected the wp-config.php config files on the wordpress units. Those are temporary fixes until I can get the wordpress-services charm fixed.

Peter Mahnke (peterm-ubuntu) wrote :

Michael,

we are also having issues with our youtube field as well, it seems all the links to videos are lost each time there is an update.

could you look at this bug as well? https://bugs.launchpad.net/resource-centre/+bug/1485625

Peter

Changed in resource-centre:
status: New → Triaged

Hi Michael,

Just writing to see if this was ever resolved, we're about to change the permalink structure on insights and could do with the WordPress core functionality of finding the slug to be fixed.

All the best,

Graham.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers