Memory leak in dbus server connections

Bug #1680044 reported by Alexandros Frantzis on 2017-04-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
repowerd
Medium
Alexandros Frantzis

Bug Description

For example:

valgrind --show-leak-kinds=definite --leak-check=full bin/repowerd-adapter-tests --gtest_filter=AUnityDisplay.turn_on_request_contacts_dbus_service

==18796== 187 (40 direct, 147 indirect) bytes in 1 blocks are definitely lost in loss record 943 of 992
==18796== at 0x4C2EB45: calloc (vg_replace_malloc.c:711)
==18796== by 0x54709E0: g_malloc0 (in /lib/x86_64-linux-gnu/libglib-2.0.so.0.5200.0)
==18796== by 0x4F070CF: ??? (in /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0.5200.0)
==18796== by 0x546E7F2: ??? (in /lib/x86_64-linux-gnu/libglib-2.0.so.0.5200.0)
==18796== by 0x546F8DA: g_markup_parse_context_parse (in /lib/x86_64-linux-gnu/libglib-2.0.so.0.5200.0)
==18796== by 0x4F07E56: g_dbus_node_info_new_for_xml (in /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0.5200.0)
==18796== by 0x5E1BA9: repowerd::DBusEventLoop::register_object_handler(_GDBusConnection*, char const*, char const*, std::function<void (_GDBusConnection*, char const*, char const*, char const*, char const*, _GVariant*, _GDBusMethodInvocation*)> const&)::{lambda()#1}::operator()() const (dbus_event_loop.cpp:85)
==18796== by 0x5E2838: std::_Function_handler<void (), repowerd::DBusEventLoop::register_object_handler(_GDBusConnection*, char const*, char const*, std::function<void (_GDBusConnection*, char const*, char const*, char const*, char const*, _GVariant*, _GDBusMethodInvocation*)> const&)::{lambda()#1}>::_M_invoke(std::_Any_data const&) (functional:1731)
==18796== by 0x4D3FCD: std::function<void ()>::operator()() const (functional:2127)
==18796== by 0x5E9214: (anonymous namespace)::GSourceContext::static_call((anonymous namespace)::GSourceContext*) (event_loop.cpp:46)
==18796== by 0x546B229: g_main_context_dispatch (in /lib/x86_64-linux-gnu/libglib-2.0.so.0.5200.0)
==18796== by 0x546B5DF: ??? (in /lib/x86_64-linux-gnu/libglib-2.0.so.0.5200.0)

Alexandros Frantzis (afrantzis) wrote :

This is caused by an upstream gdbus issue tracked here: https://bugzilla.gnome.org/show_bug.cgi?id=780924

Alexandros Frantzis (afrantzis) wrote :

Fixed upstream.

Changed in repowerd:
status: In Progress → Fix Released
status: Fix Released → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.