Ren'Py get stuck when using {nw}

Bug #735187 reported by franck_v on 2011-03-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ren'Py
Fix Released
Medium
Tom Rothamel

Bug Description

I have the following script:

label start:
"line1{nw}"
"line2{nw}"
"line3{nw}"

Sometime Ren'Py will randomly get stuck between (for example) line2 and line3.
If I move the mouse then the script resumes.

I enclosed the stacktrace when this happens.

I tried to debug the problem and it seems to happen when the system receives a TIMEEVENT immediately followed by a joystick event (<Event(7-JoyAxisMotion {'joy': 0, 'value': -0.012787255470442824, 'axis': 0})>).
Both events are merged together and then the joystick event is ignored causing the system to wait indefinitely.

franck_v (franck-vdl) wrote :
Tom Rothamel (renpytom) wrote :

Fixed. Thanks for taking the time to track this down, and figure out the cause. That made fixing it easy.

Changed in renpy:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → renpytom (renpytom)
milestone: none → 6.12.1
Tom Rothamel (renpytom) on 2011-05-02
Changed in renpy:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments