configuration test mode

Bug #306583 reported by Zivago Lee on 2008-12-09
2
Affects Status Importance Assigned to Milestone
Remote HellaNZB GUI
High
Clément Lorteau

Bug Description

Is there a way to add a configuration test mode? Right now (as I'm still learning how to configure the application), I think i must have mis-typed something so whenever I start up the application, I cannot click anywhere on it (ie. hung state) or anything because it looks like it is trying to connect to the remote server.

If I leave it up for a while I get this in the console but still cannot access the application:

Disconnected: (110, 'Connection timed out')

It would be great if there could be some type of test mode when setting up the configuration. Now it looks like I may have to delete the current configuration (Can you tell me where it is?) to get access to the application again.

Any other thoughts?

The thing is the status bar reports error messages which i think are sufficient to check the configuration, but the interface freezing prevents it from being displayed. That's what, in my opinion, needs to be fixed first.

To manually clean the configuration, start 'gconf-editor' and deactivate the 'host' key under /apps/remote-hellanzb-gui.

BTW, have you got hellanzb installed on the host that you specified in the configuration?

Again, thanks for the report.

Changed in remote-hellanzb-gui:
assignee: nobody → northern-lights
importance: Undecided → High
status: New → Confirmed

OK, now the network calls can timeout ; so if the server doesn't answer, the connection will timeout and the statusbar will say it (timeout is 5 seconds).

Also, the backend is now threaded.

I'll try to make a release tomorrow.

Changed in remote-hellanzb-gui:
status: Confirmed → Fix Committed
Changed in remote-hellanzb-gui:
status: Fix Committed → Fix Released
Zivago Lee (zivagolee) wrote :

I installed 0.9 and it times out gracefully now, so that is good.

Not sure if I should put this in another thread because it is not part of this bug here is how I am setup and this how I thought the SSH configuration is supposed to be setup:

Host with hellanzb has a firewall but ssh is running. I thought the ssh config is supposed to do some type of port forward type of thing to the hellanzb host? I don't think it's working that way, however. Is there to get some useful debug output of what it is doing?

Let's continue here; i'll put it into 'answers' later though, because i think this question is important.

To remotely monitor the queue, SSH is not needed. SSH is simply needed to enqueue files that are located on your local computer (the client). So if you can't connect to the hellanzb daemon, it's not because of SSH. Are you sure that the hellanzb daemon is configured to allow connections from other hosts?

Zivago Lee (zivagolee) wrote :

Ok, I'm able to connect to the remote hellanzb host by doing my own ssh port forward since port 8760 is not open on the firewall. I setup the host as localhost and then in the .ssh/config I put in:

host remotehellanzbhost
LocalForward 8760 localhost:8760

Is there a way to have it do that automatically? I guess that would be a wishlist :)

Right, i thought about it and i then I forgot. I'll add it to the TODO list. I also plan to implement the use of http proxyies.

Zivago Lee (zivagolee) wrote :

Great.. thanks a lot! So far it works great... for some reason I could not get LottaNZB's remote feature to work but this was easy to setup and with the use of hellafox, it's very nice.

Yup, hellanzb can't be enqueued remote files, and other front-ends seem to have missed that ; that's why i made this app that copies nzb files through ssh first.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers