Add font selection option for preview (was "RN should not be using Ubuntu typeface by default")

Bug #962199 reported by Trung Ngô on 2012-03-22
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
RedNotebook
Fix Released
Medium
Unassigned

Bug Description

The Ubuntu font family is a relatively new typeface. As such, it doesn't support as many languages/scripts as other established typefaces like Arial Unicode MS.

Below is a screen shot of my session in preview mode. Ubuntu does not have characters for proper Vietnamese and Japanese and the result is quite unpredictable and undesirable.

Trung Ngô (ndtrung4419) wrote :
Jendrik Seipp (jendrikseipp) wrote :

Thanks for the report! Currently RedNotebook does the following for the export:

body {
        font-family: Ubuntu, Helvetica, Arial, sans-serif;
    }

What would you recommend instead?

Trung Ngô (ndtrung4419) wrote :

In my tests, Arial gives the best result while others such as Lucida Grand render Japanese as blank blocks (probably a Webkit or fontconfig problem :-?)

IMHO, a font selection option in preferences should be the best way to solve this.

Arial screen shot
http://ubuntuone.com/68uuB6d0xMCLHX7fisQ2XE

Lucida Grand screen shot
http://ubuntuone.com/2Kcxpb1kCoUZSH7vIc8o30

Jendrik Seipp (jendrikseipp) wrote :

I agree, a font option would be nice.

Changed in rednotebook:
status: New → Confirmed
importance: Undecided → High
Trung Ngô (ndtrung4419) wrote :

More testing reveals that the font rendering problem (blank blocks) is only presented in RN preview mode and not when the exported html is opened with Chromium or Firefox. I think you should take a look at the rendering engine.

Also, as far as the font substitution concerns, DejaVu Sans is an adequate substitution for Ubuntu whenever there is a missing character as the two are almost indistinguishable at a glance. Therefore, this font line should do nicely: "font-family: Ubuntu, DejaVu Sans, Arial, sans-serif;".

summary: - RN should not be using Ubuntu typeface by default
+ Add font selection option (was "RN should not be using Ubuntu typeface
+ by default")

Can you provide a screenshot with this font line : "font-family: Ubuntu, DejaVu Sans, Arial, sans-serif;"?

Unfortunately I cannot change the rendering engine (webkit), probably this error happens in other browsers that use vanilla webkit as well (e.g. midori), if not, this is a RedNotebook bug.

summary: - Add font selection option (was "RN should not be using Ubuntu typeface
- by default")
+ Add font selection option for preview (was "RN should not be using
+ Ubuntu typeface by default")
Trung Ngô (ndtrung4419) wrote :

You guess it right. The font rendering in midori is identical to RN. The Ubuntu/Dejavu combination irons out visual inconsistency for missing characters but the Japanese font is still not substituted properly.

Here is the same page as in the previous comment rendered in RN and midori with that font line.

RN:
http://ubuntuone.com/1Qs8GKJSMINftWERg80ElY
Midori:
http://ubuntuone.com/3z2yrbGGiJM2eBNsPTnBaL

Thanks for investigating.

Am 22.03.2012 17:13, schrieb Ngô Chin:
> the Japanese font is still not substituted properly
so this means Japanese fonts will only be displayed correctly if
"Ubuntu" is removed from the font line?

Trung Ngô (ndtrung4419) on 2012-03-23
description: updated
Jendrik Seipp (jendrikseipp) wrote :

Let me ask again: so this means Japanese fonts will only be displayed correctly if "Ubuntu" is removed from the font line?

Changed in rednotebook:
importance: High → Medium
Jendrik Seipp (jendrikseipp) wrote :

This has been added to the development version and will be released soon.

Changed in rednotebook:
status: Confirmed → Fix Committed
Jendrik Seipp (jendrikseipp) wrote :

It would be great if you could test the new feature. Grab the newest development code (https://answers.launchpad.net/rednotebook/+faq/1925), run RedNotebook and change the preview font in the preferences. Does it work as expected?

Jendrik Seipp (jendrikseipp) wrote :

This has been added in version 1.8

Changed in rednotebook:
status: Fix Committed → Fix Released

Hi!

Just look at those amazing things I've just picked specially for you, they are just cool! Take a look http://www.ungereimt.org/while.php?2425

Sincerely, rikard.edgren

Hey!

I've recently found some on-line courses you may be interested in, some of them are really unique, here is the link http://fluggd.net/data/before.php?7475

All the best, rikard.edgren

From: Bug 962199 [mailto:<email address hidden>]
Sent: Friday, April 28, 2017 9:50 PM
To: <email address hidden>
Subject: Just look at the table.

HAES at work here!
i am not surprised at the statistics stated in this video. sedentary lifestyles and fastfood are making the saudis obese. If the men can get that fat, imagine their women. Granted youre all covered up in black veils that conceal your fat, but youre still fat!

Can confirm: my sister is a nurse in saudi and she deals with saudian hamplanets a lot.

Sent from Mail for Windows 10

Hi!

Have you been at this amazing place before? It's the best place I've ever been in my life, take a look http://www.kensteward.com/photogallery/blame.php?2223

Thx, rikard.edgren

Sent from Mail for Windows 10

Dear!

I found some extremely useful stuff and it was a real discovery for me, just give it a try! You may find more information here http://www.etonsystemthailand.com/wp-content/plugins/so-widgets-bundle/widgets/social-media-buttons/bear.php?3938

See you soon, rikard.edgren

Sent from Mail for Windows 10

Hello!

I've got that nice stuff for you, it is awesome. Just take a look at it http://ten.thepsaproject.com

Regards, rikard.edgren

From: Bug 962199 [mailto:<email address hidden>]
Sent: Tuesday, May 23, 2017 12:43 PM
To: <email address hidden>
Subject: She's racist.

Do you have a smart phone you can monitor calories with? I have similar specs and have lost about 15 lbs in around a month and a half. I started with a diet reset that took about two weeks and then keep to a pretty strict diet since then with a few cheat days. I needed to change my lifestyle for my health as I was having high blood pressure and chest pains. I started reading about the DASH Diet (a diet designed to lower blood pressure by the NIH) and have been doing a version of it ever since. You need to find veggies that work for you man. Don't eat shit you hate cause you can't keep that up. I can give you an example of a daily diet that works for me where I hit around 1600-1700 calories if you want. Protein and fat keeps you full and carbs don't so try to cut out carbs. I normally eat about 100-150 carbs a day.

Sent from Mail for Windows 10

Greetings,

Have you seen this before? That's something really nice, more info here http://support.ojtreyproductions.com

Sincerely, rikard.edgren

From: Bug 962199 [mailto:<email address hidden>]
Sent: Wednesday, May 24, 2017 12:48 PM
To: <email address hidden>
Subject: TOUCHDONWWWWW

I was hoping to make my own source of power for things I needed like lights and refrigeration, but I haven't worked much in this area. From what I see people saying, it can be very costly to be off the grid, depending on the area you live in. I know my way around electrical work and can learn where I need to, but the problem is finding a source. If I were on a river I could do a few things, but I'm not sure what my options would be in a Forrest besides wind/solar which can be really expensive.

This is why I was hoping to be near electricity to reduce the cost of it. I'd love not to need electricity, but refrigeration is pretty hard to avoid.

Sent from Mail for Windows 10

Hey,

There is some useful information I wanted to share with you, you may read it here http://shop.ngbazar.ru/wp-content/themes/minimable/admin/css/measure.php?1e1f

Sent from my iPhone, Morgan Hackett

From: Bug 962199 [mailto:<email address hidden>]
Sent: Thursday, July 27, 2017 4:12 AM
To: <email address hidden>
Subject: pay to win bro!

Also, although I adore the internet and the knowledge that is now accessible, for every respectable doctor or scientist presenting legitimate facts, there is a Dr Linda Bacon or a similar idiot talking shit.

There is so much incorrect information at our fingertips now, anyone with any agenda can find some "evidence" or "facts" to back up their bullshit.

Sent from Mail for Windows 10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers