Raspberry Pi display not supported

Bug #1499046 reported by Diederik
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Raspbian
Fix Released
Undecided
Unassigned

Bug Description

A user and one of my co-developers reported that the Raspberry Pi display doesn't work with the current firmware.
Installing the raspberrypi-bootloader package, but not changing/removing the kernel/initramfs lines in /boot/config.txt made it work. So an update of the raspberrypi-bootloader-nokernel package should be enough.

raspbian-ua-netinst bug: https://github.com/debian-pi/raspbian-ua-netinst/issues/282

Revision history for this message
Diederik (didi-debian) wrote :
Revision history for this message
Diederik (didi-debian) wrote :

My co-developer confirmed that with the firmware files from that commit, the Raspberry Pi display does indeed work, both during the installation and after that.

Revision history for this message
Diederik (didi-debian) wrote :

In the changelog.Debian I noticed that the firmware files are from (the commit from) 23 September 2015 (960832a6c2590635216c296b6ee0bebf67b21d50) which is associated with kernel version 4.1.7.
I don't know (or understand) why the firmware files are tied to a kernel version, but apparently they are.

In that light, wouldn't it be safer to use the firmware files from the commit I mentioned earlier?
Or are there other factors which would make it unfeasible to base the release on that commit? Besides time, I can think of at least another one: the RPF hasn't released that version/commit and thereby given their 'seal of approval' that it is safe to be released.

(just wondering)

Revision history for this message
Diederik (didi-debian) wrote :

Both have now reported back and both have said that the Raspberry Pi display works with the updated firmware :-)

Revision history for this message
Diederik (didi-debian) wrote :

I also did a comparison of 'dmesg' with the firmware from the package and the one from the earlier mentioned commit (from the 3.18 branch) and there's quite a difference. I haven't noticed any problems* and my technical skills aren't good enough to tell whether it could cause problems, but I'll attach 2 samples in case you can (and are interested).

* the testing I can do is limited, especially regarding DT as I don't have any HAT devices.

Revision history for this message
Diederik (didi-debian) wrote :
Revision history for this message
Diederik (didi-debian) wrote :
Revision history for this message
Diederik (didi-debian) wrote :

It looks like there is a bit more needed to get touch to work, see https://github.com/debian-pi/raspbian-ua-netinst/issues/282#issuecomment-154174144 and based on that I found the following commit: https://github.com/raspberrypi/linux/commit/2f04df7aef19d4e087c80fa7371e3f5139233570

So, in addition to the updated firmware, the following changes seem to be needed in the kernel:
CONFIG_INPUT_TOUCHSCREEN=y
CONFIG_TOUCHSCREEN_RPI_FT5406=m

Revision history for this message
Diederik (didi-debian) wrote :

plugwash: What's the status on making a new firmware release?

Diederik (didi-debian)
tags: added: kernel
tags: added: firmware
Revision history for this message
Diederik (didi-debian) wrote :

Found the 'definitive' answer:
https://github.com/raspberrypi/linux/issues/1147#issuecomment-143855321

CONFIG_INPUT_TOUCHSCREEN=y
CONFIG_TOUCHSCREEN_RPI_FT5406=m
rpi-ft5406-overlay.dtb

The last one was introduced with:
https://github.com/raspberrypi/firmware/commit/856e2e1907a7f7058289c30268515c8cbf3fa5e3
So my suggestion to use the last commit from 3.18 wouldn't cut it as that commit was introduced with 4.0.6.

Revision history for this message
Diederik (didi-debian) wrote :

I have no touchscreen, so can't verify exactly. But both the kernel parameters are set now and there is a rpi-ft5406.dtbo file, which I guess is a compiled version of the needed .dtb.
Therefor closing this issue.

Changed in raspbian:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers