vlc compiled to wrong libav version

Bug #1416538 reported by Ayke on 2015-01-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Raspbian
Undecided
Unassigned

Bug Description

MPV says:

$ mpv -version
Warning: mpv was compiled against a different version of libav than the shared
library it is linked against. This can expose subtle ABI compatibility issues
and can lead to misbehavior and crashes.
mpv 0.6.2 (C) 2000-2014 mpv/MPlayer/mplayer2 projects
 built on 2014-11-05T17:49:41
libav library versions:
   libavutil 54.3.0
   libavcodec 56.0.0 (runtime 56.1.0)
   libavformat 56.1.0
   libswscale 3.0.0
   libavfilter 5.0.0
   libavresample 2.1.0

So I think it just needs to be recompiled.

I don't know whether it is related, but sometimes libmpv1 just doesn't seem to work so well. Small problems that I don't remember seeing before.

$ dpkg -l | grep mpv
ii libmpv-dev:armhf 0.6.2-2
ii libmpv1:armhf 0.6.2-2
ii mpv 0.6.2-2

$ dpkg -l | grep Libav
ii libavcodec56:armhf 6:11.2-1+rpi1
ii libavdevice55:armhf 6:11.2-1+rpi1
ii libavfilter5:armhf 6:11.2-1+rpi1
ii libavformat56:armhf 6:11.2-1+rpi1
ii libavresample2:armhf 6:11.2-1+rpi1
ii libavutil54:armhf 6:11.2-1+rpi1
ii libswscale3:armhf 6:11.2-1+rpi1

(I removed 'armhf' and the descriptions of the dpkg output).

System: Debian jessie, installed via netinst (https://github.com/debian-pi/raspbian-ua-netinst).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers