Plymouth packaging/script error

Bug #1401005 reported by Gavin Lambert on 2014-12-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Raspbian
Undecided
Unassigned

Bug Description

On current Raspbian Wheezy, installing the "plymouth" package (currently at 0.8.5) results in being unable to create the required initramfs -- update-initramfs displays the following error:

    # sudo update-initramfs -c -k `uname -r`
    update-initramfs: Generating /boot/initrd.img-3.12.34+
    cp: cannot stat `/usr/lib/arm-linux-gnueabihf/pango/1.6.0/module-files.d/libpango1.0-0.modules': No such file or directory
    E: /usr/share/initramfs-tools/hooks/plymouth failed with return 1.
    update-initramfs: failed for /boot/initrd.img-3.12.34+ with 1.

The file (or actually the whole "pango" directory) is indeed not present on the Pi. According to the upstream Debian package website, these files are supposed to be in the package "libpango1.0-0". As this package is installed on my Pi and the files are missing, it appears not.

I asked about this on StackExchange (http://raspberrypi.stackexchange.com/a/24909/20612) and was told that the package seems to think it contains those files, but actually doesn't. They also seemed to think that it was odd that two packages "libpango1.0-0" and "libpango-1.0-0" existed simultaneously with nearly identical contents.

I tried building the 0.8.8 package from upstream source and this had the same issue. (Let me know if anyone wants the defuzzed patches.)

I then commented out the lines that were trying to copy these files from `/usr/share/initramfs-tools/hooks/plymouth` and (while still running 0.8.8) it could then build the initramfs, and seems to be running correctly after that (although I also had to do some additional hackery with init.d scripts to get it to play nice with nodm). So it appears these files may not actually be needed anyway?

I'm not sure whether the correct resolution is to remove these lines from the plymouth script or to track down the missing pango files and get them back in somewhere.

(At one point I also tried getting it to work on Jessie, which has 0.9.0, but eventually gave up; I don't recall at the moment what the specific issue was but I do recall seeing a lot of Internet posts about problems with 0.9.0. But that's a separate issue and might just be insufficient perseverance.)

Pander (pander) wrote :

Gavin, is this reproducible on Raspbian Stretch or Buster? It was reported for Wheezy which is no longer supported. If it is reproducible, please report for which version of Raspbian, otherwise close this issue. Thanks.

Pander (pander) on 2019-07-17
Changed in raspbian:
status: New → Incomplete
tags: added: wheezy
Launchpad Janitor (janitor) wrote :

[Expired for Raspbian because there has been no activity for 60 days.]

Changed in raspbian:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers