Raspian 12-20-2013 - Kernel Panic - USB?

Bug #1267696 reported by Richard Andrews on 2014-01-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Raspbian
Undecided
Unassigned

Bug Description

When playing streaming audio using mpc/mpd, the kernel panics after a few minutes.

The summary of the message is

kernel BUG at drivers/usb/host/dwc_otg_hcd.c:1355!
Internal error: Oops - Bug: 0 [#1} PREEMPT ARM

I can duplicate this on two different Rpis and on two different sd cards.

Here is my setup.

RPI - UK made purchased early Dec. 2013- Allied Elect.
WIFI - realtek
usb hub
mpd and mpc installed
I2C bus enabled

# lsusb
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 0bda:8174 Realtek Semiconductor Corp. RTL8192SU 802.11n WLAN Adapter
Bus 001 Device 005: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 006: ID 04d9:1203 Holtek Semiconductor, Inc. Keyboard
Bus 001 Device 007: ID 045e:0039 Microsoft Corp. IntelliMouse Optical

# uname -a
Linux lee-pi-wifi 3.10.24+ #614 PREEMPT Thu Dec 19 20:38:42 GMT 2013 armv6l GNU/Linux

The only thing worth mentioning is that I2C is enabled.
Bluetooth was configured but the Bluetooth USB adapter has been unplugged from the USB bus.
IPV6 addrs have been commented out of /etc/hosts.

Pictures of the stack trace are at:

https://github.com/raspberrypi/linux/issues/491

I believe that the issue is related to the USB driver and shows up when moderate but constant use occurs.

apt-get update and apt-get upgrade performed but panics continue.

If any additional info is needed, please contact me via email.

Workaround is to use a previous release of Raspbian.

Richard Andrews (rich-andrews) wrote :

Sorry if I am using terminology that is SYSV based. I was raised in a AT&T USL laboratory.

Richard Andrews (rich-andrews) wrote :

This issue still occurs with the 2014-01-07 release

Diederik (didi-debian) wrote :

As that bug seems to be closed with a fix, I'm marking this bug the same.

If you disagree, feel free to reopen it and provide the output of 'uname -a'.

Changed in raspbian:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers