Rapid Photo Downloader

Panasonic MOD format and duplicate filename issue

Reported by Brian M Stempien on 2011-11-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Rapid Photo Downloader
Medium
Damon Lynch

Bug Description

I use a Panasonic SD Camcorder that uses a directory hierarchy that splits the files by day, and then reuses the same filename on different days. So for example I have a card with DCIM MISC and SD_VIDEO toplevel folders, then in the SD_VIDEO folder there are directories PRG001, PRG002, etc. Each directory has at least a MOV001.MOD file in it, which corresponds to a single Start record/Stop record clip. If the directory has more than one clip, all is well, but if PRG001 has one clip then when the program goes to process PRG002 there is conflict copying to the /tmp/rpd-tmp-xxx directory. I am using 0.4.1-1.fc16 on Fedora 16.

Related branches

Damon Lynch (dlynch3) wrote :

Thanks for your bug report. It looks like I'll need to randomize the names of the files when they're stored in the temporary directory, which is what I did in earlier versions.

Changed in rapid:
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → Damon Lynch (dlynch3)
milestone: none → 0.4.3
Damon Lynch (dlynch3) on 2011-11-20
Changed in rapid:
status: Confirmed → Fix Committed
Damon Lynch (dlynch3) on 2012-01-08
Changed in rapid:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers