Rapid Photo Downloader

Previously downloaded images are displayed when new card inserted

Reported by subeditor on 2011-06-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Rapid Photo Downloader
Low
Damon Lynch

Bug Description

Steps to reproduce:
1. Insert card A and download some images from it.
2. Remove card A. Downloaded images are still displayed in index.
3. Insert card B. Press Ctrl-R (refresh) -> in index you may see images from both cards in a jumble.

Is it expected behavior? What is purpose of keeping downloaded images in index?

Related branches

Damon Lynch (dlynch3) on 2011-11-20
Changed in rapid:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Damon Lynch (dlynch3)
milestone: none → 0.4.3
Damon Lynch (dlynch3) wrote :

It's a bug that the images stay after the refresh, so I'll fix that for sure. But it's important they are not removed even after the card is ejected, because if the user is using the auto eject/unmount feature, there would be no way of telling that that the images had been downloaded.

Damon Lynch (dlynch3) on 2011-12-28
Changed in rapid:
status: Confirmed → In Progress
Damon Lynch (dlynch3) on 2011-12-28
Changed in rapid:
status: In Progress → Fix Committed
Damon Lynch (dlynch3) on 2012-01-08
Changed in rapid:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers