Rapid Photo Downloader

Add support for Samsung's SRW raw files (or any custom mask)

Reported by Oleg Yermakov on 2010-09-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Rapid Photo Downloader
Medium
Damon Lynch

Bug Description

Samsung had recently made the worst thing I could expect from them — they invented the new .SRW raw file format for their new NX series cameras. Proof & examples: http://www.photographyblog.com/reviews/samsung_nx10_review/sample_images/

The problem is: nothing supports it currently, except for Samsung's branded raw processor for Windows® (Silkypix or something like that) and Adobe's Lightroom & DNG converter.

Rapid photo downloader doesn't download it too.

I was even more upset when I realized there's no option to specify my own file copy mask.

So my current workflow is
1) Converting the photos using DNG converter (it works flawlessly under wine) from memory card to my hard drive
2) Copying the JPEG and MP4 files to the same place manually.

I ask you to
1) Add SRW to your supported file masks.
2) Add an option to specify my own masks or extensions.
3) Add support for custom scripts ( #511646 ) so I could convert photos after copying.

I guess «convert raws to .dng» could be a great example of custom script and you could include it with RPD.

Related branches

Thanks for your bug report. Rapid Photo Downloader depends on pyexiv2, which
in turns depends on exiv2. Exiv2 does not yet support Samsung's unique file
format. Until it does, there is not much I can do about it. You could file a
feature request with the exiv2 developers.

The program specifically excludes some extensions because the program will
not function without exiv2 supporting them. Changing this functionality is
possible -- but it would make the program even more complex than it already
is, and I think it is a bad idea.

I need help from other people in order to be able to develop plugin
functionality that would help with things like file conversion. Can you
help? You do not need to be a programmer. It would be very helpful for those
people who want to do other things too, like change file permissions, add
GPS tagging, etc.

Oleg Yermakov (epushiron) wrote :

Okay, I've posted my request to exiv2 developers at http://dev.exiv2.org/issues/726

This exact feature request is now made pretty clear.

Also I thought you can support custom file masks via video (not photo) copying framework.

Plugins and help in development: I am ready to help. I do some bash & python scripting, so I can make some Nautilus-style (or your custom style aswell) scripts if I have some free time and ideas. More about nautilus scripts: http://www.brighthub.com/hubfolio/matthew-casperson/articles/83630.aspx . I can send you .dng conversion script for example when it's ready. My email is public if you wish to discuss about it.

Oleg Yermakov (epushiron) wrote :

Reading EXIF tags from the SRW images work almost fine:

$ exiv2 print SAM_6972-test.srw
File name : SAM_6972-test.srw
File size : 28138208 Bytes
MIME type : image/tiff
Image size : 0 x 0
Camera make : SAMSUNG
Camera model : NX10
Image timestamp : 2010:09:09 00:14:46
Image number :
Exposure time : 1/8 s
Aperture : F2
Exposure bias : 0 EV
Flash : No flash
Flash bias :
Focal length : 30.0 mm
Subject distance:
ISO speed : 800
Exposure mode : Aperture priority
Metering mode : Multi-segment
Macro mode :
Image quality :
Exif Resolution :
White balance : Auto
Thumbnail : None
Copyright :
Exif comment :

Image size is shown as zero althrough it's populated in EXIF tags. Also, altering tags breaks the SRW file. More info at http://dev.exiv2.org/issues/726#note-2

It is fantastic you are doing this investigation. I am hopeful Rapid Photo
Downloader can be used to read the exif information from these files, using
the existing versions of pyexiv2 and exiv2. Currently, Rapid Photo
Downloader does not write to the photos. So the file alteration should not
be a problem in terms of downloading.

Damon Lynch (dlynch3) on 2010-09-23
Changed in rapid:
importance: Undecided → Medium
assignee: nobody → Damon Lynch (dlynch3)
status: New → In Progress
Damon Lynch (dlynch3) wrote :

Please test the version that has been uploaded to launchpad code hosting. You can get the code by running:

bzr branch lp:rapid

Changed in rapid:
status: In Progress → Fix Committed
Oleg Yermakov (epushiron) wrote :

> Please test the version that has been uploaded to launchpad code
> hosting. You can get the code by running:

Yes, it works fine. Photos are detected, all basic metadata I use is
read, and they are copied without problems.

No previews, just as expected. How do you get the preview images? What
should be fixed for it to work?

Pic of the process: http://i.imgur.com/3BrMk.png

P/S: exiv2 developers said their more or less full SRW support could
possibly be added next week.

Damon Lynch (dlynch3) wrote :

The previews are extracted from within the RAW image. I'm surprised it
doesn't work because when I tested it with an SRW file from a
dpreview.comcamera review of the EX1, the preview worked fine
(although it's
orientation was wrong). Unfortunately you'll need to wait until a exiv2
about to be released is packaged for your distribution, which can take a
while. Hopefully this new version will not break any existing applications,
which will make the process easier.

Damon Lynch (dlynch3) on 2010-10-25
Changed in rapid:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers