Rapid Photo Downloader

AttributeError: 'module' object has no attribute 'Image'

Reported by bautz on 2010-04-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Rapid Photo Downloader
High
Damon Lynch

Bug Description

[bautz@mypc ~]$ rapid-photo-downloader
Traceback (most recent call last):
  File "/usr/bin/rapid-photo-downloader", line 3, in <module>
    import rapid.rapid
  File "/usr/lib/python2.6/site-packages/rapid/rapid.py", line 76, in <module>
    import metadata
  File "/usr/lib/python2.6/site-packages/rapid/metadata.py", line 39, in <module>
    class MetaData(pyexiv2.Image):
AttributeError: 'module' object has no attribute 'Image'

And rapid-photo-downloader doesn't start. It's a py2exiv compatibility problem?
Tested with both pyexiv2 version 0.2.0 and version 0.2.1.
Previously it worked

Related branches

Damon Lynch (dlynch3) wrote :

Yes, this is a known bug. Pyexiv2 changed it's API with the new version. I didn't have time yet to change Rapid Photo Downloader to be able to use both versions of Pyexiv2. This fix is the most urgent change needed to Rapid Photo Downloader.

Changed in rapid:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Damon Lynch (dlynch3)
Damon Lynch (dlynch3) on 2010-05-15
Changed in rapid:
status: Confirmed → In Progress
Damon Lynch (dlynch3) wrote :

This bug has been fixed. If you like to help test it, that would be helpful. The fix is in the version of the code that can be found on launchpad.

To get the latest code from launchpad, ensure bazaar is installed on your system, then get the latest version by executing:
bzr branch lp:rapid

Thanks.

Changed in rapid:
status: In Progress → Fix Committed

Tested with bzr branch as of today; the fix works for me on Gentoo Amd64.

Damon Lynch (dlynch3) on 2010-05-31
Changed in rapid:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers