Rapid Photo Downloader

wishlist: disable auto-mounted HD partitions

Reported by royden on 2009-05-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Rapid Photo Downloader
Medium
Damon Lynch

Bug Description

I dual-boot and the XP partition is auto-mounted in /media. The scanning of this partition by RPD is unnecessary and it would be good to be able to disable this.

Very good programme this. Become my downloader of choice, particularly with b2 and the camera function! Great stuff!

Royden

Related branches

Mikko Ruohola (polarfox) wrote :

I've also got this problem. My problem is kinda huge, because I Dualboot AND my photos are on NTFS drive.. over 200GB of photos, and all are selected for automatic download ;)

Damon Lynch (dlynch3) wrote :

My guess is that you both have the automatic detection of Portable Storage Devices activated. If you turn it off, the devices will not be scanned, yes?

Mikko Ruohola (polarfox) wrote :

Yep, But I would like to have my PORTABLE storage device detected.

Damon Lynch (dlynch3) wrote :

This is a very interesting bug. On my Ubuntu system, I have numerous hard drive partitions mounted, including ext3, NTFS and vfat. They are configured in /etc/fstab. None of them are automatically detected by the program. It seems that other Linux distributions handle mount points differently. Since this is the case, it seems a way to filter what should be excluded would indeed be useful. To fix this, the logic in the code that handles mounted devices is trivial. The time consuming part is making it available via the user interface.

Meanwhile, obviously the workaround is to manually select your download path.

Mikko Ruohola (polarfox) wrote :

I think the problem is that on new ubuntu installations, NTFS etc. partitions are not in fstab, but are mounted via hald at access time on gnome. I can't even use them without logging into gnome.
But this is the way new installations work, so this might be worth of a look, if you can even recognice if the drive is really portable or not, not sure about the technical details.

How does RPD detect portable drives? I might be able to look at this problem...

royden (ryts) wrote :

I had a fstab entry for the XP partition that pointed to /media/sda1 (a legacy from Hardy perhaps?). Removing that, and ensuring that the internal partition does not auto-mount (System > Administration > Authorizations - set admin status or some such) solves the issue for me.

This will not help Mikko, as he has an image store on the ntfs partition. Unless he disables the hal auto-mount as described and sets an fstab entry to a mount point other than /media - I am assuming that this is how Damon has it and RPD polls /media to make the autodetect.

tnx,

ryts

i also want this feature be built.

i use ubuntu 9.04 and also winXP (ntfs), and everytime i use RPD it detects and download photos from that partition.

Damon Lynch (dlynch3) on 2009-11-15
Changed in rapid:
assignee: nobody → Damon Lynch (dlynch3)
importance: Undecided → Medium
milestone: none → 0.1.0
status: New → In Progress
Damon Lynch (dlynch3) on 2009-11-23
Changed in rapid:
status: In Progress → Fix Committed
Damon Lynch (dlynch3) on 2009-11-23
Changed in rapid:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers