Rapid Photo Downloader

Program unresponsive when download source has many images

Reported by Damon Lynch on 2009-04-27
4
Affects Status Importance Assigned to Milestone
Rapid Photo Downloader
High
Damon Lynch

Bug Description

This bug shows up in multiple places:

When the program is starting
When a device is inserted
When the preference for auto detect image device unchecked (especially because it defaults to the home directory)

The problem is that every directory and subdirectory under the path is being scanned for images. This should take place as a thread or something similar.

Related branches

Damon Lynch (dlynch3) on 2009-04-27
Changed in rapid:
assignee: nobody → dlynch3
importance: Undecided → High
Damon Lynch (dlynch3) on 2009-04-27
summary: - Program unreponsive when download source has many images
+ Program unresponsive when download source has many images
Damon Lynch (dlynch3) on 2009-05-06
Changed in rapid:
milestone: none → 0.0.9
status: New → In Progress
Damon Lynch (dlynch3) on 2009-05-09
Changed in rapid:
status: In Progress → Fix Committed
Damon Lynch (dlynch3) on 2009-05-12
Changed in rapid:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers