Device scan failed with pymediainfo 5.02

Bug #1907943 reported by Justin Allard on 2020-12-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Rapid Photo Downloader
Medium
Damon Lynch

Bug Description

While scanning my SD card, RPD gives an error stating "Device scan failed" "Sorry, an unexpected problem occurred while scanning disk."

I tried un-mounting and re-mounting my SD card. I am able to view and access the contents of the card through my file manager, Dolphin. I tried rebooting, same issue. Uninstalled and re-installed RPD, same error. I have not tried with a different SD card.

Bug report file is attached.

Justin Allard (justinmi) wrote :
Damon Lynch (dlynch3) on 2020-12-13
Changed in rapid:
status: New → Triaged
assignee: nobody → Damon Lynch (dlynch3)
importance: Undecided → Medium
milestone: none → 0.9.25
Damon Lynch (dlynch3) on 2020-12-13
summary: - Device scan failed
+ Device scan failed with pymediainfo 5.02
Damon Lynch (dlynch3) wrote :

This is not a bug in Rapid Photo Downloader. I was able to replicate this bug in pymediainfo 5.0.2 only. Upgrade to pymediainfo 5.0.3 to fix the problem. You should file a bug report in arch / manjaro against the package pymediainfo so the package maintainer knows about the problem and knows to update it to 5.0.3 ASAP.

Meanwhile if you want Rapid Photo Downloader to run on your system today, do this (NOT using sudo) to install the latest pymediainfo for your user only:

python3 -m pip install -U pymediainfo

Then when arch / manjaro updates the system package, do this to uninstall your user version (which is recommended on a rolling release distro like yours):

python3 -m pip uninstall pymediainfo

Changed in rapid:
status: Triaged → Invalid
Damon Lynch (dlynch3) wrote :

One more thing: please report back here with the arch / manjaro bug report so I can share it with others when other arch / manjaro users ask me about it. Thanks.

Justin Allard (justinmi) wrote :

Thank you for the information, I have reported this to the Manjaro team here: https://forum.manjaro.org/t/update-pymediainfo-to-5-0-3/42793

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments