Fails to run - Could not load the Qt platform plugin "xcb"

Bug #1889770 reported by Kevin Benjamin on 2020-07-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Rapid Photo Downloader
Medium
Damon Lynch

Bug Description

After running install, the application fails to run. The following is in the /etc/syslog file. Re-installing does not fix the problem.

ul 31 07:18:37 net.damonlynch.rapid_photo_downloader.desktop[89906]: qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
Jul 31 07:18:37 net.damonlynch.rapid_photo_downloader.desktop[89906]: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
Jul 31 07:18:37 net.damonlynch.rapid_photo_downloader.desktop[89906]: Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, webgl, xcb.
Jul 31 07:18:37 net.damonlynch.rapid_photo_downloader.desktop[89906]: Fatal Python error: Aborted
Jul 31 07:18:37 net.damonlynch.rapid_photo_downloader.desktop[89906]: Current thread 0x00007f3ac995e740 (most recent call first):
Jul 31 07:18:37 net.damonlynch.rapid_photo_downloader.desktop[89906]: File "/home/user/.local/lib/python3.8/site-packages/raphodo/viewutils.py", line 464 in any_screen_scaled_qt
Jul 31 07:18:37 net.damonlynch.rapid_photo_downloader.desktop[89906]: File "/home/user/.local/lib/python3.8/site-packages/raphodo/viewutils.py", line 480 in any_screen_scaled
Jul 31 07:18:37 net.damonlynch.rapid_photo_downloader.desktop[89906]: File "/home/user/.local/lib/python3.8/site-packages/raphodo/rapid.py", line 6385 in main
Jul 31 07:18:37 net.damonlynch.rapid_photo_downloader.desktop[89906]: File "/home/user/.local/bin/rapid-photo-downloader", line 8 in <module>
Jul 31 07:18:37 systemd[1730]: gnome-launched-net.damonlynch.rapid_photo_downloader.desktop-89906.scope: Succeeded.

Related branches

Damon Lynch (dlynch3) wrote :

You’ve provided truly no context whatsoever, such as the distro you’re running it on, the log files, etc.

So I'm going to take a guess and assume you're running on an Debian derived distro of some kind.

Fix it like this:

sudo apt-get install libxkbcommon-x11-0

Kevin Benjamin (kbenj) wrote :

The distro is Ubuntu 20.04.1 LTS. Here are the results of the install you suggested.

Reading package lists... Done
Building dependency tree
Reading state information... Done
libxkbcommon-x11-0 is already the newest version (0.10.0-1).
libxkbcommon-x11-0 set to manually installed.
The following package was automatically installed and is no longer required:
  libllvm9
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 13 not upgraded.

Damon Lynch (dlynch3) wrote :

In that case follow the instructions here:

https://damonlynch.net/rapid/documentation/#reportproblem

Assuming the user interface is still failing to open at all, you must run the tar command listed under the instructions for 0.9.23.

Until this step is taken there is very little I can suggest.

Kevin Benjamin (kbenj) wrote :

The interface is not opening, and there is no path .cache/rapid-photo-downloader.

cldershem (cldershem) wrote :

Unsure of what actually caused this, but ran into the same issue. Was able to solve it with `sudo apt-get install libqt5x11extras5`.

Christoph (ich777) wrote :

Ran into the same problem with my Docker container for Unraid.
Thank you for the solution from @cldershem by installing the package: libqt5x11extras5
After installing the package it is working again.

Damon Lynch (dlynch3) on 2020-09-14
Changed in rapid:
milestone: none → 0.9.25
assignee: nobody → Damon Lynch (dlynch3)
importance: Undecided → Medium
status: New → Fix Committed

+1 libqt5x11extras5 package solves the problem for me as well.

Damon Lynch (dlynch3) on 2020-12-19
Changed in rapid:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers