Unable to generate thumbnails or download from Fujifilm X-H1

Bug #1876344 reported by Corey Zeller on 2020-05-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Rapid Photo Downloader
High
Damon Lynch

Bug Description

Camera is detected and appears under devices. Files are listed in the main window but no thumbnails are generated. Status bar says generating thumbnails but never completes. If I click Download no files are downloaded. If I disable thumbnail generation, and then click Download, the status bar says Downloading but no files are downloaded.

The camera model is Fujifilm X-H1. It is supported by gphoto2 and thumbnails/import work in other applications including digikam. GVFS is not running.

Log file is attached.

Related branches

Corey Zeller (cbz2) wrote :
Damon Lynch (dlynch3) wrote :

Please also include the configuration file found in the directory ~/.config/Rapid Photo Downloader/.

See for more detail https://damonlynch.net/rapid/help.html

Attached.

On Fri, May 1, 2020 at 1:30 PM Damon Lynch <email address hidden> wrote:

> Please also include the configuration file found in the directory
> ~/.config/Rapid Photo Downloader/.
>
> See for more detail https://damonlynch.net/rapid/help.html
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1876344
>
> Title:
> Unable to generate thumbnails or download from PTP camera
>
> Status in Rapid Photo Downloader:
> New
>
> Bug description:
> Camera is detected and appears under devices. Files are listed in the
> main window but no thumbnails are generated. Status bar says
> generating thumbnails but never completes. If I click Download no
> files are downloaded. If I disable thumbnail generation, and then
> click Download, the status bar says Downloading but no files are
> downloaded.
>
> The camera model is Fujifilm X-H1. It is supported by gphoto2 and
> thumbnails/import work in other applications including digikam. GVFS
> is not running.
>
> Log file is attached.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/rapid/+bug/1876344/+subscriptions
>

Thanks. Due to time-sensitive academic commitments it may take me some weeks (or longer) to deal with this bug. It's hard to say.

Changed in rapid:
status: New → Triaged
Damon Lynch (dlynch3) wrote :

Corey Zeller do you have access to another camera to try? If not a camera, a smart phone? I ask Because I cannot replicate this bug with my own cameras.

If it is specific to the Fujifilm camera, then we can narrow down the cause.

If it occurs with all cameras, then that indicates something else to look for.

summary: - Unable to generate thumbnails or download from PTP camera
+ Unable to generate thumbnails or download from Fujifilm X-H1

Hi,

Thumbnails generated correctly with my LG V30/VS996 smartphone connected
over USB in photo transfer mode, and with my Fujifilm X-T1 camera. I also
successfully downloaded from the X-T1. I tried the X-H1 in a different USB
port as well and with both USB 2.0 and 3.0 cables; the problem persists
regardless.

Log file is attached showing the smartphone, failed X-H1 attempts, and the
successful X-T1 download.

On Sat, May 2, 2020 at 12:40 PM Damon Lynch <email address hidden> wrote:

> Corey Zeller do you have access to another camera to try? If not a
> camera, a smart phone? I ask Because I cannot replicate this bug with my
> own cameras.
>
> If it is specific to the Fujifilm camera, then we can narrow down the
> cause.
>
> If it occurs with all cameras, then that indicates something else to
> look for.
>
> ** Summary changed:
>
> - Unable to generate thumbnails or download from PTP camera
> + Unable to generate thumbnails or download from Fujifilm X-H1
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1876344
>
> Title:
> Unable to generate thumbnails or download from Fujifilm X-H1
>
> Status in Rapid Photo Downloader:
> Triaged
>
> Bug description:
> Camera is detected and appears under devices. Files are listed in the
> main window but no thumbnails are generated. Status bar says
> generating thumbnails but never completes. If I click Download no
> files are downloaded. If I disable thumbnail generation, and then
> click Download, the status bar says Downloading but no files are
> downloaded.
>
> The camera model is Fujifilm X-H1. It is supported by gphoto2 and
> thumbnails/import work in other applications including digikam. GVFS
> is not running.
>
> Log file is attached.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/rapid/+bug/1876344/+subscriptions
>

Damon Lynch (dlynch3) wrote :

So just to be absolutely clear: you've observed the problem occurring only with the Fujifilm X-H1 camera?

Ensure only the X-H1 is attached. Ensure it is not open (mounted) in any other program, including any Gnome or KDE program. Then from the command line run this:

gphoto2 --list-files

Does this exactly match the file list on the camera's memory cards?

Corey Zeller (cbz2) wrote :

Correct, I have only experienced this problem with the X-H1.

With the X-H1 attached, the output of gphoto2 --list-files exactly matches
the contents of the SD card.

The camera is not mounted in any other program.

On Sat, May 2, 2020 at 1:45 PM Damon Lynch <email address hidden> wrote:

> So just to be absolutely clear: you've observed the problem occurring
> only with the Fujifilm X-H1 camera?
>
> Ensure only the X-H1 is attached. Ensure it is not open (mounted) in any
> other program, including any Gnome or KDE program. Then from the command
> line run this:
>
> gphoto2 --list-files
>
> Does this exactly match the file list on the camera's memory cards?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1876344
>
> Title:
> Unable to generate thumbnails or download from Fujifilm X-H1
>
> Status in Rapid Photo Downloader:
> Triaged
>
> Bug description:
> Camera is detected and appears under devices. Files are listed in the
> main window but no thumbnails are generated. Status bar says
> generating thumbnails but never completes. If I click Download no
> files are downloaded. If I disable thumbnail generation, and then
> click Download, the status bar says Downloading but no files are
> downloaded.
>
> The camera model is Fujifilm X-H1. It is supported by gphoto2 and
> thumbnails/import work in other applications including digikam. GVFS
> is not running.
>
> Log file is attached.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/rapid/+bug/1876344/+subscriptions
>

Damon Lynch (dlynch3) wrote :

I have attached an unreleased version that contains an extra line of additional debugging information that could help determine what is going wrong with this particular camera.

Please do this:

Delete all the files in ~/.cache/rapid-photo-downloader/log

Uninstall the Arch packaged Rapid Photo Downloader, but not its dependencies (very important).

Install Python pip and Python wheel if they're not already installed

Install the attached tar file (do not use sudo):
python pip install --do-deps rapid-photo-downloader-0.9.24.tar.gz

Ensure only the Fuji Fujifilm X-H1 is on the system (no other SD cards, cameras etc.)

Run:
~/.local/bin/rapid-photo-downloader

After the thumbnails fail to generate, from within the program run Report a Problem, and click save to create a tar file with the saved log and config files. Attach that tar file to this bug report.

When you want to uninstall this version, use pip:
pip uninstall rapid-photo-downloader

Corey Zeller (cbz2) wrote :

Attached.

On Sun, May 3, 2020 at 9:15 AM Damon Lynch <email address hidden> wrote:

> I have attached an unreleased version that contains an extra line of
> additional debugging information that could help determine what is going
> wrong with this particular camera.
>
> Please do this:
>
> Delete all the files in ~/.cache/rapid-photo-downloader/log
>
> Uninstall the Arch packaged Rapid Photo Downloader, but not its
> dependencies (very important).
>
> Install Python pip and Python wheel if they're not already installed
>
> Install the attached tar file (do not use sudo):
> python pip install --do-deps rapid-photo-downloader-0.9.24.tar.gz
>
> Ensure only the Fuji Fujifilm X-H1 is on the system (no other SD cards,
> cameras etc.)
>
> Run:
> ~/.local/bin/rapid-photo-downloader
>
> After the thumbnails fail to generate, from within the program run
> Report a Problem, and click save to create a tar file with the saved log
> and config files. Attach that tar file to this bug report.
>
> When you want to uninstall this version, use pip:
> pip uninstall rapid-photo-downloader
>
>
> ** Attachment added: "rapid-photo-downloader-0.9.24.tar.gz"
>
> https://bugs.launchpad.net/rapid/+bug/1876344/+attachment/5365715/+files/rapid-photo-downloader-0.9.24.tar.gz
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1876344
>
> Title:
> Unable to generate thumbnails or download from Fujifilm X-H1
>
> Status in Rapid Photo Downloader:
> Triaged
>
> Bug description:
> Camera is detected and appears under devices. Files are listed in the
> main window but no thumbnails are generated. Status bar says
> generating thumbnails but never completes. If I click Download no
> files are downloaded. If I disable thumbnail generation, and then
> click Download, the status bar says Downloading but no files are
> downloaded.
>
> The camera model is Fujifilm X-H1. It is supported by gphoto2 and
> thumbnails/import work in other applications including digikam. GVFS
> is not running.
>
> Log file is attached.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/rapid/+bug/1876344/+subscriptions
>

Corey Zeller (cbz2) wrote :

I commented out line 58 in raphodo/rescan.py and now it generates
thumbnails and downloads from the X-H1 successfully.

58 #assert camera.camera_has_folders_to_scan()

On Sun, May 3, 2020 at 12:17 PM Corey Zeller <email address hidden> wrote:

> Attached.
>
> On Sun, May 3, 2020 at 9:15 AM Damon Lynch <email address hidden> wrote:
>
>> I have attached an unreleased version that contains an extra line of
>> additional debugging information that could help determine what is going
>> wrong with this particular camera.
>>
>> Please do this:
>>
>> Delete all the files in ~/.cache/rapid-photo-downloader/log
>>
>> Uninstall the Arch packaged Rapid Photo Downloader, but not its
>> dependencies (very important).
>>
>> Install Python pip and Python wheel if they're not already installed
>>
>> Install the attached tar file (do not use sudo):
>> python pip install --do-deps rapid-photo-downloader-0.9.24.tar.gz
>>
>> Ensure only the Fuji Fujifilm X-H1 is on the system (no other SD cards,
>> cameras etc.)
>>
>> Run:
>> ~/.local/bin/rapid-photo-downloader
>>
>> After the thumbnails fail to generate, from within the program run
>> Report a Problem, and click save to create a tar file with the saved log
>> and config files. Attach that tar file to this bug report.
>>
>> When you want to uninstall this version, use pip:
>> pip uninstall rapid-photo-downloader
>>
>>
>> ** Attachment added: "rapid-photo-downloader-0.9.24.tar.gz"
>>
>> https://bugs.launchpad.net/rapid/+bug/1876344/+attachment/5365715/+files/rapid-photo-downloader-0.9.24.tar.gz
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1876344
>>
>> Title:
>> Unable to generate thumbnails or download from Fujifilm X-H1
>>
>> Status in Rapid Photo Downloader:
>> Triaged
>>
>> Bug description:
>> Camera is detected and appears under devices. Files are listed in the
>> main window but no thumbnails are generated. Status bar says
>> generating thumbnails but never completes. If I click Download no
>> files are downloaded. If I disable thumbnail generation, and then
>> click Download, the status bar says Downloading but no files are
>> downloaded.
>>
>> The camera model is Fujifilm X-H1. It is supported by gphoto2 and
>> thumbnails/import work in other applications including digikam. GVFS
>> is not running.
>>
>> Log file is attached.
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/rapid/+bug/1876344/+subscriptions
>>
>

Damon Lynch (dlynch3) wrote :

Thanks for the additional information. I assume you had only the Fuji Fujifilm X-H1 is on the system. Why is the device /mnt/sdcard listed under "My Computer"?

It is very strange that libgphoto2 would be returning an empty list of folders on the camera, but still allowing access to the actual files located in the same folders. Very strange indeed. It could be a firmware bug in the camera or a bug in libgphoto2. I guess I'll just have to relax the assertion and turn it into logged warning.

Damon Lynch (dlynch3) on 2020-05-03
Changed in rapid:
importance: Undecided → High
assignee: nobody → Damon Lynch (dlynch3)
milestone: none → 0.9.24
status: Triaged → Fix Committed
Damon Lynch (dlynch3) wrote :

When you reinstall the Arch version, you must uninstall the version you installed using pip. Mixing the two versions on one system is not good.

Changed in rapid:
status: Fix Committed → Fix Released
Corey Zeller (cbz2) wrote :

/mnt/sdcard is an empty mount point I created. There is nothing mounted
there.

Thanks for your help. Let me know if I can provide any additional info
related to this.

On Sun, May 3, 2020 at 1:50 PM Damon Lynch <email address hidden> wrote:

> When you reinstall the Arch version, you must uninstall the version you
> installed using pip. Mixing the two versions on one system is not good.
>
> ** Changed in: rapid
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1876344
>
> Title:
> Unable to generate thumbnails or download from Fujifilm X-H1
>
> Status in Rapid Photo Downloader:
> Fix Released
>
> Bug description:
> Camera is detected and appears under devices. Files are listed in the
> main window but no thumbnails are generated. Status bar says
> generating thumbnails but never completes. If I click Download no
> files are downloaded. If I disable thumbnail generation, and then
> click Download, the status bar says Downloading but no files are
> downloaded.
>
> The camera model is Fujifilm X-H1. It is supported by gphoto2 and
> thumbnails/import work in other applications including digikam. GVFS
> is not running.
>
> Log file is attached.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/rapid/+bug/1876344/+subscriptions
>

Damon Lynch (dlynch3) wrote :

Thanks for quickly getting back to me with the additional information I requested. Makes fixing it much easier.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers