Install 0.9.0a3 under Debian 8 Jessie -

Bug #1589051 reported by Hubiz
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Rapid Photo Downloader
Status tracked in Pyqt
Pyqt
Invalid
High
Damon Lynch

Bug Description

How can i install libmediainfo0v5 under Debian8?

./install.py rapid-photo-downloader-0.9.0a3.tar.gz
The following package is unknown on your system: libmediainfo0v5

Tags: faq
Revision history for this message
Damon Lynch (dlynch3) wrote :

Almost certainly the package name has changed.

Figure out the best one from this list:
https://packages.debian.org/search?keywords=mediainfo&searchon=names

Install the correct one, and modify my installer script if you know how (it's easy), or let me know if you don't know how.

Either way please let me know what the correct name is, so I can enhance the script.

Revision history for this message
Hubiz (talk) wrote :

I my case (Linux zeus 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt20-1+deb8u3 (2016-01-17) x86_64 GNU/Linux
)
i must change libmediainfo0v5 to libmediainfo0

I have installed
apt-get install libmediainfo0

and then i start the install.py-script again.

After installation is start rpd

:~/Downloads$ rapid-photo-downloader
Traceback (most recent call last):
  File "/home/bee/bin/rapid-photo-downloader", line 7, in <module>
    from raphodo.rapid import main
  File "/home/bee/.local/lib/python3.4/site-packages/raphodo/rapid.py", line 71, in <module>
    from PyQt5.QtCore import (QThread, Qt, QStorageInfo, QSettings, QPoint,
ImportError: cannot import name 'QStorageInfo'
:~/Downloads$ rapid-photo-downloader
Traceback (most recent call last):
  File "/home/bee/bin/rapid-photo-downloader", line 7, in <module>
    from raphodo.rapid import main
  File "/home/bee/.local/lib/python3.4/site-packages/raphodo/rapid.py", line 71, in <module>
    from PyQt5.QtCore import (QThread, Qt, QStorageInfo, QSettings, QPoint,
ImportError: cannot import name 'QStorageInfo'

Revision history for this message
Damon Lynch (dlynch3) wrote :

Your version of Debian is too old to run the latest version of Rapid Photo Downloader.

The minimum requirements are PyQt 5.4 or newer, and Qt. 5.4 or newer. I should clarify the requirements to reflect the need for Qt 5.4 or newer, since PyQt 5 versions are not strictly tied to Qt 5 versions.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers