Strange input task in the report

Bug #1570328 reported by Andrey Kurilin on 2016-04-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Rally
Undecided
Alexander Maretskiy
Changed in rally:
assignee: nobody → Alexander Maretskiy (maretskiy)
Changed in rally:
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/306489

Changed in rally:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/306489
Committed: https://git.openstack.org/cgit/openstack/rally/commit/?id=404f0fab683adbf12c016aea4f2bf89a402ff461
Submitter: Jenkins
Branch: master

commit 404f0fab683adbf12c016aea4f2bf89a402ff461
Author: Alexander Maretskiy <email address hidden>
Date: Fri Apr 15 17:52:21 2016 +0300

    [Context] Fix side effect changes of context config

    Since context configuration passed to Context.__init__() is
    a mutable type (dict or list), sometimes we have unexpected
    changes done by unpredictable code (for example, in wrappers).

    This patch uses types `common.utils.LockedDict' and `tuple'
    for locking this data from further changes.

    Also there was missing unit test for Context.__init__()
    with DEFAULT_CONFIG set - this unit test is added.

    Change-Id: Ic1f11281fcf95b35d9fbb3ee82cb1d67f1d8abd7
    Closes-Bug: #1570328

Changed in rally:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers