SeaGenerator: Cannot read index file index.txt.gz

Bug #1322802 reported by Dee on 2014-05-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Radkarte
High
luckyguess

Bug Description

I've just downloaded the latest version and just have done "ant dist" without any changes. Now I get the following error (excerpt):

generate_BaseMap_map:
     [copy] Copying 1 file to /home/dee/Downloads/radkarte/build
     [echo] Executing mkgmap...
    [apply] Time started: Fri May 23 22:12:56 CEST 2014
    [apply] Schwerwiegend (SeaGenerator): /home/dee/Downloads/radkarte/build/59000002.osm.pbf: Cannot read index file index.txt.gz
    [apply] java.util.zip.ZipException: error in opening zip file
    [apply] Schwerwiegend (LocationHook): /home/dee/Downloads/radkarte/build/59000005.osm.pbf: Disable LocationHook because bounds directory is unusable. Dir: /home/dee/Downloads/radkarte/./cache/downloads/precomp_bounds.zip

I have attached the complete build.log.

i tried to removed the options --precomp-sea, --generate-sea and --bounds, but then I do not get a gmapsupp.img and only several different imgs.

Dee (deedw) wrote :
Dee (deedw) wrote :

Okay, I've found the reason. I tried to unzip the downloaded "precomp_bounds.zip" and "precomp_sea.zip" manually and it said it's not a zip-file. A "file precomp_bounds.zip" tells me it's a "HTML document, ASCII text". And if I open it with an editor I see a webpage with the info "The requested page cannot be found".

So http://navmaps.eu/boundaries?task=weblink.go&id=2 will not work anymore. I don't know what has changed ...

Dee (deedw) wrote :

Sorry, once again: The workaround (removing the --precomp lines) has worked, but the directory for the images has changed since last year. It's now build/dist, so I hadn't found the img-files yesterday.

Simeon (simeon5) wrote :

The download location of the precomp_sea.zip and precomp_bounds.zip needs to be changed. The provider Radkarte uses seems to have stopped providing them. But they can be downloaded from the mkgmap webpage:
http://www.mkgmap.org.uk/download/mkgmap.html

luckyguess (luckyguess) wrote :

I change the used URLs in a few minutes.
Please reopen, if I made some mistakes.

Changed in radkarte:
status: New → Fix Committed
assignee: nobody → luckyguess (luckyguess)
importance: Undecided → High
luckyguess (luckyguess) on 2014-05-25
Changed in radkarte:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments