qutim crashes at start

Bug #1300338 reported by Gannet on 2014-03-31
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
qutim
Critical
Unassigned

Bug Description

After upgrade to Trusty, qutim crashes every time trying to start. What console says:

Core::ProfileCreationPage::ProfileCreationPage(QWidget*)???
QSocketNotifier: Invalid socket 12 and type 'Read', disabling...
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon
!!!!!!! 'kde-plasma' '0x7f6321a827c0' 'oxygen'

(qutim:2723): GLib-GObject-WARNING **: cannot register existing type 'GstObject'

(qutim:2723): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(qutim:2723): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed

(qutim:2723): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(qutim:2723): GLib-GObject-CRITICAL **: g_object_newv: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

(qutim:2723): GStreamer-CRITICAL **: gst_object_ref_sink: assertion 'object != NULL' failed

(qutim:2723): GStreamer-CRITICAL **: gst_registry_get_feature_list: assertion 'GST_IS_REGISTRY (registry)' failed

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: qutim 0.3.2+201402241634-52~ubuntu14.04.1 [origin: LP-PPA-qutim-qutim]
Uname: Linux 3.14.0-031400-generic x86_64
ApportVersion: 2.14-0ubuntu1
Architecture: amd64
CrashDB: qutim
CurrentDesktop: KDE
Date: Mon Mar 31 19:25:59 2014
InstallationDate: Installed on 2012-05-06 (693 days ago)
InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120423)
SourcePackage: qutim
ThirdParty: True
UpgradeStatus: Upgraded to trusty on 2014-02-23 (35 days ago)

Gannet (ken20001) wrote :
description: updated
Dmitry (crazydimson) wrote :

На Ubuntu 14.04 не запускается qutIM. При запуске через консоль:

!!!!!!! 'ubuntu' '0x0' ''

(qutim:2408): GLib-GObject-WARNING **: cannot register existing type 'GstObject'

(qutim:2408): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(qutim:2408): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed

(qutim:2408): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(qutim:2408): GLib-GObject-CRITICAL **: g_object_newv: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

(qutim:2408): GStreamer-CRITICAL **: gst_object_ref_sink: assertion 'object != NULL' failed

(qutim:2408): GStreamer-CRITICAL **: gst_registry_get_feature_list: assertion 'GST_IS_REGISTRY (registry)' failed

Ядро: 3.13.0-23-generic
Рабочий стол: Unity
qutIM version 0.3.2.0
Using Qt version 4.8.6
GPL v3 or any later
Последнее обновление системы: 07.04.2014 в 17:30

Александр (venom13) wrote :

У меня ещё к этому добавляется:
"
Core::ProfileCreationPage::ProfileCreationPage(QWidget*)???
QSocketNotifier: Invalid socket 16 and type 'Read', disabling...
QSocketNotifier: Invalid socket 16 and type 'Read', disabling...
QSocketNotifier: Invalid socket 20 and type 'Write', disabling...
QSocketNotifier: Invalid socket 16 and type 'Read', disabling...
"

Александр (venom13) wrote :

Все?
Разработка прекращена?

Dmitry Veltishev (vdmit) wrote :

Yes, having the same problem after upgrading to 14.04.
Is there a way to get complete debug log, etc. to discover actual reason of this failure?

Gannet (ken20001) on 2014-04-22
description: updated
Александр (venom13) wrote :

Блин, багу почти месяц!
Я уже начинаю привыкать к другим клиентам ..... :(

Roman Zhukov (jadeite) wrote :

Kubuntu 14.04, plasma-netbook:

!!!!!!! 'kde-plasma' '0x7f77c70fd7c0' 'oxygen'

(qutim:28630): GLib-GObject-WARNING **: cannot register existing type 'GstObject'

(qutim:28630): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(qutim:28630): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed

(qutim:28630): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(qutim:28630): GLib-GObject-CRITICAL **: g_object_newv: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

(qutim:28630): GStreamer-CRITICAL **: gst_object_ref_sink: assertion 'object != NULL' failed

(qutim:28630): GStreamer-CRITICAL **: gst_registry_get_feature_list: assertion 'GST_IS_REGISTRY (registry)' failed

GreatIncvizitor (mihanus) wrote :

Та же картина..

Kubuntu 14.04:
!!!!!!! 'kde-plasma' '0xae9d4270' 'oxygen'

(qutim:7267): GLib-GObject-WARNING **: cannot register existing type 'GstObject'

(qutim:7267): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(qutim:7267): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed

(qutim:7267): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(qutim:7267): GLib-GObject-CRITICAL **: g_object_newv: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

(qutim:7267): GStreamer-CRITICAL **: gst_object_ref_sink: assertion 'object != NULL' failed

(qutim:7267): GStreamer-CRITICAL **: gst_registry_get_feature_list: assertion 'GST_IS_REGISTRY (registry)' failed

ferdelan (ferdelan) wrote :

Ok. This seems to be libgstreamer-0.10 and libgstreammer-1.0 is mixed.

For me solution is simple:

sudo rm -f /usr/lib/qutim/plugins/libquetzal.so

Better solution is fix Cmake build scripts to rebuild libquetzal with libgstreammer-1.0 instead of libgstreamer-0.10

Dmitry Veltishev (vdmit) wrote :

Wow, it's really working! Ferdelan, thanks a lot!
Another "more correct" solution for Ubuntu is to remove `qutim-plugin-quetzal` package.

About rebulding from source: I was not successful in this under Ubuntu 14.04 (and 12.04 too). Some patches found in inet discussions were helpful, but only partially. I'm going to file separate bug for this.

Dmitry Veltishev (vdmit) wrote :

One more notice: it seems that there is an architecture problem in QutIM: actually, just one plugin failed, and whole application failed to start. It's enormous and plugins should be more "isolated".

SlavikZ (slavikz) wrote :

There's also another workaround - just change in ~/.config/qutim/profile.json SoundBackend parameter from PhononSoundBackend to either MultimediaSoundBackend or SDLSoundBackend.

As far as I understand the problem is that libquetzal use libgstreamer-0.10, while phonon backend use libgstreamer-1.0.

Tretyakov R (roman-i) on 2014-04-24
Changed in qutim:
status: New → Incomplete
importance: Undecided → Critical
Stierlitz (parovozy4) on 2014-04-24
Changed in qutim:
assignee: nobody → Stierlitz (parovozy4)
Tretyakov R (roman-i) on 2014-04-24
Changed in qutim:
status: Incomplete → In Progress
Tretyakov R (roman-i) on 2014-04-26
Changed in qutim:
status: In Progress → Fix Committed
Stierlitz (parovozy4) on 2014-04-29
Changed in qutim:
assignee: Stierlitz (parovozy4) → nobody
Obsidian (grandobsidian) wrote :

Kubuntu 14.04.Когда починят?

"Невозможно загрузить библиотеку /usr/lib/qutim/plugins/libindicator.so: (libmessaging-menu-qt.so.12: невозможно открыть разделяемый объектный файл: Нет такого файла или каталога)"
"Невозможно загрузить библиотеку /usr/lib/qutim/plugins/libindicator.so: (libmessaging-menu-qt.so.12: невозможно открыть разделяемый объектный файл: Нет такого файла или каталога)"
Core::ProfileCreationPage::ProfileCreationPage(QWidget*)???
QSocketNotifier: Invalid socket 12 and type 'Read', disabling...
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon
!!!!!!! 'kde-plasma' '0x7f26de1437c0' 'Compass-KDE'
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
KDE Daemon (kded) already running.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
kbuildsycoca4 running...
Hspell: can't open /usr/share/hspell/hebrew.wgz.sizes.

(qutim:6240): GLib-GObject-WARNING **: cannot register existing type 'GstObject'

(qutim:6240): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(qutim:6240): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed

(qutim:6240): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(qutim:6240): GLib-GObject-CRITICAL **: g_object_newv: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

(qutim:6240): GStreamer-CRITICAL **: gst_object_ref_sink: assertion 'object != NULL' failed

(qutim:6240): GStreamer-CRITICAL **: gst_registry_get_feature_list: assertion 'GST_IS_REGISTRY (registry)' failed

V-ctor (radioengineer) on 2014-06-28
Changed in qutim:
status: Fix Committed → Fix Released
V-ctor (radioengineer) wrote :

Слйчайно сменил статус на "выпушено", кто имеет права откатите.
Accidentally choose "Released" please change it to previous state (commited ?).

Gannet (ken20001) on 2014-06-28
Changed in qutim:
status: Fix Released → New
status: New → Fix Committed
Tonal (tonal-promsoft) wrote :
Download full text (13.3 KiB)

Падает при попытке подключится к vk.com
Вот стек:

Application: qutIM Instant Messenger (qutim), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f338159e7c0 (LWP 9433))]

Thread 12 (Thread 0x7f335987b700 (LWP 9435)):
#0 0x00007f337f39dda3 in select () at ../sysdeps/unix/syscall-template.S:81
#1 0x00007f3359f14523 in ?? () from /usr/lib/x86_64-linux-gnu/libtcl8.6.so
#2 0x00007f337ee5a182 in start_thread (arg=0x7f335987b700) at pthread_create.c:312
#3 0x00007f337f3a647d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 11 (Thread 0x7f334bfc7700 (LWP 9439)):
#0 0x00007f337e9bc61a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1 0x00007f337e9bc979 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2 0x00007f337e97a699 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007f337e97af03 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4 0x00007f337e97b0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5 0x00007f33800a07be in QEventDispatcherGlib::processEvents (this=0x7f33440008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6 0x00007f33800720af in QEventLoop::processEvents (this=this@entry=0x7f334bfc6e20, flags=...) at kernel/qeventloop.cpp:149
#7 0x00007f33800723a5 in QEventLoop::exec (this=this@entry=0x7f334bfc6e20, flags=...) at kernel/qeventloop.cpp:204
#8 0x00007f337ff6ec5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#9 0x00007f337ff7132f in QThreadPrivate::start (arg=0x292adb0) at thread/qthread_unix.cpp:349
#10 0x00007f337ee5a182 in start_thread (arg=0x7f334bfc7700) at pthread_create.c:312
#11 0x00007f337f3a647d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 10 (Thread 0x7f3343583700 (LWP 9443)):
#0 0x00007f337ee5d7ee in __pthread_mutex_unlock_usercnt (decr=1, mutex=0x7f333c000a60) at pthread_mutex_unlock.c:57
#1 __GI___pthread_mutex_unlock (mutex=0x7f333c000a60) at pthread_mutex_unlock.c:310
#2 0x00007f337e9bc9b1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007f337e97aa20 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4 0x00007f337e97af7b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5 0x00007f337e97b0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6 0x00007f33800a07be in QEventDispatcherGlib::processEvents (this=0x7f333c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#7 0x00007f33800720af in QEventLoop::processEvents (this=this@entry=0x7f333c0013d0, flags=...) at kernel/qeventloop.cpp:149
#8 0x00007f33800723a5 in QEventLoop::exec (this=0x7f333c0013d0, flags=...) at kernel/qeventloop.cpp:204
#9 0x00007f336bea94f2 in QCA::SyncThread::run() () from /usr/lib/x86_64-linux-gnu/libqca.so.2
#10 0x00007f337ff7132f in QThreadPrivate::start (arg=0x4223670) at thread/qthread_unix.cpp:349
#11 0x00007f337ee5a182 in start_thread (arg=0x7f3343583700) at pthread_create.c:312
#12 0x00007f337f3a647d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 9 (Thread 0x7f33412d7700 (LWP 945...

Changed in qutim:
status: Fix Committed → Confirmed
Tonal (tonal-promsoft) on 2015-06-21
no longer affects: qutim (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers