qutim crashes during creating new jabber account

Bug #1278136 reported by Gannet on 2014-02-09
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
qutim
Undecided
Unassigned

Bug Description

Application: qutim (0.3.1.0)
KDE Platform Version: 4.12.1
Qt Version: 4.8.6
Operating System: Linux 3.13.2-031302-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
Checking "I want to create new Jabber account" in Settings --> Add new account causes crash every time.

-- Backtrace:
Application: qutIM Instant Messenger (qutim), signal: Floating point exception
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7feca21da7c0 (LWP 2952))]

Thread 13 (Thread 0x7fec6f9e9700 (LWP 3202)):
#0 0x00007fec9fa7405f in __pthread_mutex_unlock_usercnt (mutex=0x7fec68000a60, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1 0x00007fec9f5d83d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2 0x00007fec9f598119 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007fec9f59863b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4 0x00007fec9f5987ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5 0x00007feca0cb9af6 in QEventDispatcherGlib::processEvents (this=0x7fec680008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6 0x00007feca0c8b30f in QEventLoop::processEvents (this=this@entry=0x7fec6f9e8db0, flags=...) at kernel/qeventloop.cpp:149
#7 0x00007feca0c8b605 in QEventLoop::exec (this=this@entry=0x7fec6f9e8db0, flags=...) at kernel/qeventloop.cpp:204
#8 0x00007feca0b87c4f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#9 0x00007feca0b8a31f in QThreadPrivate::start (arg=0xff1180) at thread/qthread_unix.cpp:349
#10 0x00007fec9fa70f6e in start_thread (arg=0x7fec6f9e9700) at pthread_create.c:311
#11 0x00007fec9ffbc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 12 (Thread 0x7fec607be700 (LWP 3217)):
#0 0x00007fec9ffae6bd in read () at ../sysdeps/unix/syscall-template.S:81
#1 0x00007fec9f5d7670 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2 0x00007fec9f5981cc in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007fec9f59863b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4 0x00007fec9f5987ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5 0x00007feca0cb9af6 in QEventDispatcherGlib::processEvents (this=0x7fec500008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6 0x00007feca0c8b30f in QEventLoop::processEvents (this=this@entry=0x7fec500012d0, flags=...) at kernel/qeventloop.cpp:149
#7 0x00007feca0c8b605 in QEventLoop::exec (this=0x7fec500012d0, flags=...) at kernel/qeventloop.cpp:204
#8 0x00007fec8e468cda in QCA::SyncThread::run() () from /usr/lib/x86_64-linux-gnu/libqca.so.2
#9 0x00007feca0b8a31f in QThreadPrivate::start (arg=0x2474550) at thread/qthread_unix.cpp:349
#10 0x00007fec9fa70f6e in start_thread (arg=0x7fec607be700) at pthread_create.c:311
#11 0x00007fec9ffbc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 11 (Thread 0x7fec5d508700 (LWP 3253)):
#0 0x00007fec9fa7405f in __pthread_mutex_unlock_usercnt (mutex=0x7fec4c00dd30, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1 0x00007fec9f5d83d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2 0x00007fec9f598699 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007fec9f598b0a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4 0x00007fec89895b66 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#5 0x00007fec9f5bd0f5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6 0x00007fec9fa70f6e in start_thread (arg=0x7fec5d508700) at pthread_create.c:311
#7 0x00007fec9ffbc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 10 (Thread 0x7fec5cd07700 (LWP 3254)):
#0 pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1 0x00007fec9cebdf3b in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2 0x00007fec9cebdf79 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3 0x00007fec9fa70f6e in start_thread (arg=0x7fec5cd07700) at pthread_create.c:311
#4 0x00007fec9ffbc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 9 (Thread 0x7fec5dd09700 (LWP 3256)):
#0 0x00007fec9f598083 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1 0x00007fec9f59863b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2 0x00007fec9f5987ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007feca0cb9af6 in QEventDispatcherGlib::processEvents (this=0x7fec400008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#4 0x00007feca0c8b30f in QEventLoop::processEvents (this=this@entry=0x7fec5dd08db0, flags=...) at kernel/qeventloop.cpp:149
#5 0x00007feca0c8b605 in QEventLoop::exec (this=this@entry=0x7fec5dd08db0, flags=...) at kernel/qeventloop.cpp:204
#6 0x00007feca0b87c4f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#7 0x00007feca0b8a31f in QThreadPrivate::start (arg=0x293a8b0) at thread/qthread_unix.cpp:349
#8 0x00007fec9fa70f6e in start_thread (arg=0x7fec5dd09700) at pthread_create.c:311
#9 0x00007fec9ffbc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 8 (Thread 0x7febaffff700 (LWP 3262)):
#0 0x00007fec9ffaff7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1 0x00007fec9f5986a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2 0x00007fec9f5987ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007feca0cb9af6 in QEventDispatcherGlib::processEvents (this=0x7feba80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#4 0x00007feca0c8b30f in QEventLoop::processEvents (this=this@entry=0x7febafffed70, flags=...) at kernel/qeventloop.cpp:149
#5 0x00007feca0c8b605 in QEventLoop::exec (this=this@entry=0x7febafffed70, flags=...) at kernel/qeventloop.cpp:204
#6 0x00007feca0b87c4f in QThread::exec (this=this@entry=0x257d7f0) at thread/qthread.cpp:537
#7 0x00007feca0c6ca33 in QInotifyFileSystemWatcherEngine::run (this=0x257d7f0) at io/qfilesystemwatcher_inotify.cpp:265
#8 0x00007feca0b8a31f in QThreadPrivate::start (arg=0x257d7f0) at thread/qthread_unix.cpp:349
#9 0x00007fec9fa70f6e in start_thread (arg=0x7febaffff700) at pthread_create.c:311
#10 0x00007fec9ffbc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 7 (Thread 0x7febaf7fe700 (LWP 7763)):
#0 pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1 0x00007fec92edf1cd in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2 0x00007fec92edf209 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3 0x00007fec9fa70f6e in start_thread (arg=0x7febaf7fe700) at pthread_create.c:311
#4 0x00007fec9ffbc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 6 (Thread 0x7febbd6bd700 (LWP 7764)):
#0 pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1 0x00007fec92c1fbbd in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2 0x00007fec92f0ea76 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3 0x00007fec9fa70f6e in start_thread (arg=0x7febbd6bd700) at pthread_create.c:311
#4 0x00007fec9ffbc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 5 (Thread 0x7fec5f91d700 (LWP 7767)):
#0 0x00007fec9f5d83d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1 0x00007fec9f598119 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2 0x00007fec9f59863b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007fec9f5987ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4 0x00007feca0cb9af6 in QEventDispatcherGlib::processEvents (this=0x7febb4001700, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#5 0x00007feca0c8b30f in QEventLoop::processEvents (this=this@entry=0x7fec5f91cdb0, flags=...) at kernel/qeventloop.cpp:149
#6 0x00007feca0c8b605 in QEventLoop::exec (this=this@entry=0x7fec5f91cdb0, flags=...) at kernel/qeventloop.cpp:204
#7 0x00007feca0b87c4f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#8 0x00007feca0b8a31f in QThreadPrivate::start (arg=0x2d124a0) at thread/qthread_unix.cpp:349
#9 0x00007fec9fa70f6e in start_thread (arg=0x7fec5f91d700) at pthread_create.c:311
#10 0x00007fec9ffbc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7febaeffd700 (LWP 7791)):
#0 0x00007fec9ffaff7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1 0x00007fec9f5986a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2 0x00007fec9f5987ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007feca0cb9af6 in QEventDispatcherGlib::processEvents (this=0x7fec4c00dc20, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#4 0x00007feca0c8b30f in QEventLoop::processEvents (this=this@entry=0x7febaeffcdb0, flags=...) at kernel/qeventloop.cpp:149
#5 0x00007feca0c8b605 in QEventLoop::exec (this=this@entry=0x7febaeffcdb0, flags=...) at kernel/qeventloop.cpp:204
#6 0x00007feca0b87c4f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#7 0x00007feca0b8a31f in QThreadPrivate::start (arg=0x303d4f0) at thread/qthread_unix.cpp:349
#8 0x00007fec9fa70f6e in start_thread (arg=0x7febaeffd700) at pthread_create.c:311
#9 0x00007fec9ffbc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7febae7fc700 (LWP 7987)):
#0 0x00007fec9ffaff7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1 0x00007fec9f5986a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2 0x00007fec9f5987ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007feca0cb9af6 in QEventDispatcherGlib::processEvents (this=0x7febb0006770, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#4 0x00007feca0c8b30f in QEventLoop::processEvents (this=this@entry=0x7febae7fbdb0, flags=...) at kernel/qeventloop.cpp:149
#5 0x00007feca0c8b605 in QEventLoop::exec (this=this@entry=0x7febae7fbdb0, flags=...) at kernel/qeventloop.cpp:204
#6 0x00007feca0b87c4f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#7 0x00007feca0b8a31f in QThreadPrivate::start (arg=0x31df270) at thread/qthread_unix.cpp:349
#8 0x00007fec9fa70f6e in start_thread (arg=0x7febae7fc700) at pthread_create.c:311
#9 0x00007fec9ffbc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7feb5fffd700 (LWP 11312)):
#0 0x00007fec9ffae6bd in read () at ../sysdeps/unix/syscall-template.S:81
#1 0x00007fec9f5d7670 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2 0x00007fec9f5981cc in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007fec9f59863b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4 0x00007fec9f5987ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5 0x00007feca0cb9af6 in QEventDispatcherGlib::processEvents (this=0x30f88a0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6 0x00007feca0c8b30f in QEventLoop::processEvents (this=this@entry=0x7feb5fffcdb0, flags=...) at kernel/qeventloop.cpp:149
#7 0x00007feca0c8b605 in QEventLoop::exec (this=this@entry=0x7feb5fffcdb0, flags=...) at kernel/qeventloop.cpp:204
#8 0x00007feca0b87c4f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#9 0x00007feca0b8a31f in QThreadPrivate::start (arg=0x3a15210) at thread/qthread_unix.cpp:349
#10 0x00007fec9fa70f6e in start_thread (arg=0x7feb5fffd700) at pthread_create.c:311
#11 0x00007fec9ffbc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7feca21da7c0 (LWP 2952)):
[KCrash Handler]
#5 Jabber::JAccountWizardPage::onFinished (this=0x3a651c0, reply=<optimized out>) at /build/buildd/qutim-0.3.1+201401141738/protocols/jabber/src/protocol/jaccountwizardpage.cpp:154
#6 0x00007feca0ca0ae8 in QMetaObject::activate (sender=sender@entry=0x3a651e8, m=m@entry=0x7feca13363e0 <QNetworkAccessManager::staticMetaObject>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x7fff4862c5b0) at kernel/qobject.cpp:3539
#7 0x00007feca1053912 in QNetworkAccessManager::finished (this=this@entry=0x3a651e8, _t1=0x3af8210) at .moc/release-shared/moc_qnetworkaccessmanager.cpp:176
#8 0x00007feca1054bd2 in QNetworkAccessManagerPrivate::_q_replyFinished (this=0x39370a0) at access/qnetworkaccessmanager.cpp:1021
#9 0x00007feca0ca0ae8 in QMetaObject::activate (sender=sender@entry=0x3af8210, m=m@entry=0x7feca1339580 <QNetworkReply::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#10 0x00007feca10e6143 in QNetworkReply::finished (this=this@entry=0x3af8210) at .moc/release-shared/moc_qnetworkreply.cpp:165
#11 0x00007feca1073d90 in QNetworkReplyImplPrivate::finished (this=0x3aefc90) at access/qnetworkreplyimpl.cpp:795
#12 0x00007feca10e5b3d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x3af3ea0, _c=6472160, _id=0, _a=0x0) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:95
#13 0x00007feca0ca4e9e in QObject::event (this=0x3af3ea0, e=<optimized out>) at kernel/qobject.cpp:1194
#14 0x00007feca1506e7c in QApplicationPrivate::notify_helper (this=this@entry=0xbc2280, receiver=receiver@entry=0x3af3ea0, e=e@entry=0x3b054a0) at kernel/qapplication.cpp:4567
#15 0x00007feca150d4f0 in QApplication::notify (this=0xbc2260, receiver=0x3af3ea0, e=0x3b054a0) at kernel/qapplication.cpp:4353
#16 0x00007feca0c8c73d in QCoreApplication::notifyInternal (this=0xbc2260, receiver=receiver@entry=0x3af3ea0, event=event@entry=0x3b054a0) at kernel/qcoreapplication.cpp:953
#17 0x00007feca0c8fdaf in sendEvent (event=0x3b054a0, receiver=0x3af3ea0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xbc2470) at kernel/qcoreapplication.cpp:1577
#19 0x00007feca0c90253 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#20 0x00007feca0cba213 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#21 postEventSourceDispatch (s=0xbc3b30) at kernel/qeventdispatcher_glib.cpp:280
#22 0x00007fec9f5983b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fec9f598708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fec9f5987ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007feca0cb9ad5 in QEventDispatcherGlib::processEvents (this=0xbc3860, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#26 0x00007feca15a8cb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007feca0c8b30f in QEventLoop::processEvents (this=this@entry=0x7fff4862cdf0, flags=...) at kernel/qeventloop.cpp:149
#28 0x00007feca0c8b605 in QEventLoop::exec (this=this@entry=0x7fff4862cdf0, flags=...) at kernel/qeventloop.cpp:204
#29 0x00007feca0c90deb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#30 0x00007feca15053cc in QApplication::exec () at kernel/qapplication.cpp:3828
#31 0x000000000040d726 in main (argc=1, argv=0x7fff4862cf48) at /build/buildd/qutim-0.3.1+201401141738/core/main.cpp:71

Gannet (ken20001) on 2014-02-09
description: updated
Tretyakov R (roman-i) on 2014-04-24
Changed in qutim:
status: New → Invalid
Gannet (ken20001) wrote :

The problem is still is. qutim still crashes trying to create new Jubber account:
1. Add new account.
2. Choose Jabber.
3. Click 'I want to create new account'
4. Double click Server field
Crash !!!

Changed in qutim:
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers